summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2009-12-19 11:14:16 +0000
committerLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2009-12-19 11:14:16 +0000
commit5bae851b1e72065ba5a98366493954b3bc79c4ae (patch)
tree4da060cef5c3f80d5c442b8d2dda05e59d7a1462 /pkgs/build-support
parent76fa225eaacbf8f7ad117a1352be87fef56b2bd7 (diff)
parent405bbecba137aaf92f984f51e06721fec1c5539d (diff)
downloadnixlib-5bae851b1e72065ba5a98366493954b3bc79c4ae.tar
nixlib-5bae851b1e72065ba5a98366493954b3bc79c4ae.tar.gz
nixlib-5bae851b1e72065ba5a98366493954b3bc79c4ae.tar.bz2
nixlib-5bae851b1e72065ba5a98366493954b3bc79c4ae.tar.lz
nixlib-5bae851b1e72065ba5a98366493954b3bc79c4ae.tar.xz
nixlib-5bae851b1e72065ba5a98366493954b3bc79c4ae.tar.zst
nixlib-5bae851b1e72065ba5a98366493954b3bc79c4ae.zip
Merging from trunk. I had to give away some structure to build the native
sheevaplug kernel, so the kernel does not build in the sheevaplug right now.
I will try to fix that in next commits.


svn path=/nixpkgs/branches/stdenv-updates/; revision=19045
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/vm/default.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/pkgs/build-support/vm/default.nix b/pkgs/build-support/vm/default.nix
index 8c47fac37b62..1092812443c6 100644
--- a/pkgs/build-support/vm/default.nix
+++ b/pkgs/build-support/vm/default.nix
@@ -5,7 +5,7 @@ with pkgs;
 rec {
 
 
-  inherit (kernelPackages_2_6_29) kernel;
+  inherit (kernelPackages_2_6_32) kernel;
 
   klibcShrunk = pkgs.klibcShrunk.override { klibc = klibc_15; };
 
@@ -14,7 +14,7 @@ rec {
 
   modulesClosure = makeModulesClosure {
     inherit kernel;
-    rootModules = ["cifs" "virtio_net" "virtio_pci" "virtio_blk" "virtio_balloon" "nls_utf8"];
+    rootModules = ["cifs" "virtio_net" "virtio_pci" "virtio_blk" "virtio_balloon" "nls_utf8" "ext2" "unix"];
   };
 
 
@@ -38,7 +38,8 @@ rec {
       mknod ${dev}/null c 1 3
       mknod ${dev}/zero c 1 5
       mknod ${dev}/tty  c 5 0
-      mknod ${dev}/vda  b 253 0
+      . /sys/class/block/vda/uevent
+      mknod ${dev}/vda  b $MAJOR $MINOR
     '';
 
   
@@ -52,6 +53,7 @@ rec {
     echo -n > /etc/fstab
 
     mount -t proc none /proc
+    mount -t sysfs none /sys
 
     for o in $(cat /proc/cmdline); do
       case $o in
@@ -124,6 +126,9 @@ rec {
     mkdir -p /fs/proc
     mount -t proc none /fs/proc
 
+    mkdir -p /fs/sys
+    mount -t sysfs none /fs/sys
+
     mkdir -p /fs/etc
     ln -sf /proc/mounts /fs/etc/mtab