summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorRok Garbas <rok@garbas.si>2016-01-20 02:17:29 +0100
committerRok Garbas <rok@garbas.si>2016-01-20 02:18:22 +0100
commit36fc03edb6ad8f9c5b29bfba43d11d8526e4f682 (patch)
tree092d3fdce9408e1986e6bd69b03c334528b808dd /pkgs/build-support
parenta7ca9c2105e99e241d6b7e105de4e43ae9a2277d (diff)
downloadnixlib-36fc03edb6ad8f9c5b29bfba43d11d8526e4f682.tar
nixlib-36fc03edb6ad8f9c5b29bfba43d11d8526e4f682.tar.gz
nixlib-36fc03edb6ad8f9c5b29bfba43d11d8526e4f682.tar.bz2
nixlib-36fc03edb6ad8f9c5b29bfba43d11d8526e4f682.tar.lz
nixlib-36fc03edb6ad8f9c5b29bfba43d11d8526e4f682.tar.xz
nixlib-36fc03edb6ad8f9c5b29bfba43d11d8526e4f682.tar.zst
nixlib-36fc03edb6ad8f9c5b29bfba43d11d8526e4f682.zip
fetchgit: import impure GIT_PROXY_COMMAND and SOCKS_SERVER, fixes #8605
These environment variables allow using fetchgit with git:// URLs using
the SOCKS proxy technique described in 'Using Git with a SOCKS proxy':

  http://www.patthoyts.tk/blog/using-git-with-socks-proxy.html

Briefly, GIT_PROXY_COMMAND is set to a script which invokes connect[1],
which reads SOCKS_PROXY, which might be pointing to a local instance of
'ssh -D'.

[1] pkgs/tools/networking/connect
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/fetchgit/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/build-support/fetchgit/default.nix b/pkgs/build-support/fetchgit/default.nix
index 127693d42f2a..7f98c97fc55b 100644
--- a/pkgs/build-support/fetchgit/default.nix
+++ b/pkgs/build-support/fetchgit/default.nix
@@ -61,7 +61,7 @@ stdenv.mkDerivation {
     # easy proxy configuration.  This is impure, but a fixed-output
     # derivation like fetchurl is allowed to do so since its result is
     # by definition pure.
-    "http_proxy" "https_proxy" "ftp_proxy" "all_proxy" "no_proxy"
+    "http_proxy" "https_proxy" "ftp_proxy" "all_proxy" "no_proxy" "GIT_PROXY_COMMAND" "SOCKS_SERVER"
     ];
 
   preferLocalBuild = true;