summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2009-04-19 16:00:46 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2009-04-19 16:00:46 +0000
commit35e42d3e5c2f2b66f24aec402a5961b35070f55f (patch)
tree6d889e7a537d775a5c2d39f3e8ad748474e0e898 /pkgs/build-support
parent40f01daa819a05b956cdca0b0abdfa9f07c9e327 (diff)
downloadnixlib-35e42d3e5c2f2b66f24aec402a5961b35070f55f.tar
nixlib-35e42d3e5c2f2b66f24aec402a5961b35070f55f.tar.gz
nixlib-35e42d3e5c2f2b66f24aec402a5961b35070f55f.tar.bz2
nixlib-35e42d3e5c2f2b66f24aec402a5961b35070f55f.tar.lz
nixlib-35e42d3e5c2f2b66f24aec402a5961b35070f55f.tar.xz
nixlib-35e42d3e5c2f2b66f24aec402a5961b35070f55f.tar.zst
nixlib-35e42d3e5c2f2b66f24aec402a5961b35070f55f.zip
* Fix missing description errors.
svn path=/nixpkgs/branches/stdenv-updates/; revision=15157
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/gcc-wrapper/default.nix13
1 files changed, 6 insertions, 7 deletions
diff --git a/pkgs/build-support/gcc-wrapper/default.nix b/pkgs/build-support/gcc-wrapper/default.nix
index cbdab8b1a9aa..91b417060996 100644
--- a/pkgs/build-support/gcc-wrapper/default.nix
+++ b/pkgs/build-support/gcc-wrapper/default.nix
@@ -42,13 +42,12 @@ stdenv.mkDerivation {
   shell = if shell == "" then stdenv.shell else shell;
   
   meta =
-    if gcc != null && (gcc ? meta) then
-      removeAttrs gcc.meta ["priority"] //
-      { description = gcc.meta.description + " (wrapper script)";
-      }
-    else
-      { description = "System C compiler (wrapper script)";
-      };
+    let gcc_ = if gcc != null then gcc else {}; in
+    (if gcc_ ? meta then removeAttrs gcc.meta ["priority"] else {}) //
+    { description =
+        stdenv.lib.getAttr ["meta" "description"] "System C compiler" gcc_
+        + " (wrapper script)";
+    };
 
   # The dynamic linker has different names on different Linux platforms.
   dynamicLinker =