summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2014-07-03 10:19:57 -0400
committerShea Levy <shea@shealevy.com>2014-07-03 10:19:57 -0400
commit2fe4eb3df97955e652169fe9584fbe7eb435b7a6 (patch)
tree20b6a438f66dcf933b16c7088d6547335918ac6d /pkgs/build-support
parentcb86818789ea9c76d127090b9047c3286dcb233a (diff)
downloadnixlib-2fe4eb3df97955e652169fe9584fbe7eb435b7a6.tar
nixlib-2fe4eb3df97955e652169fe9584fbe7eb435b7a6.tar.gz
nixlib-2fe4eb3df97955e652169fe9584fbe7eb435b7a6.tar.bz2
nixlib-2fe4eb3df97955e652169fe9584fbe7eb435b7a6.tar.lz
nixlib-2fe4eb3df97955e652169fe9584fbe7eb435b7a6.tar.xz
nixlib-2fe4eb3df97955e652169fe9584fbe7eb435b7a6.tar.zst
nixlib-2fe4eb3df97955e652169fe9584fbe7eb435b7a6.zip
Make php packages available in nix-env
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/build-pecl.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/pkgs/build-support/build-pecl.nix b/pkgs/build-support/build-pecl.nix
index d84497e8019c..727ed0c21975 100644
--- a/pkgs/build-support/build-pecl.nix
+++ b/pkgs/build-support/build-pecl.nix
@@ -1,6 +1,8 @@
 { stdenv, php, autoreconfHook }:
 
-args: stdenv.mkDerivation (args // {
+args@{ name, ... }: stdenv.mkDerivation (args // {
+  name = "php-${name}";
+
   buildInputs = [ php autoreconfHook ] ++ args.buildInputs or [];
 
   makeFlags = [ "EXTENSION_DIR=$(out)/lib/php/extensions" ] ++ args.makeFlags or [];