summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJaakko Luttinen <jaakko.luttinen@iki.fi>2017-06-01 21:35:03 +0300
committerJaakko Luttinen <jaakko.luttinen@iki.fi>2017-06-05 21:14:29 +0300
commitfe53a6c17c0d6388748b593b8513b9c8cfbaf4de (patch)
tree94d6e7dd1307dbbb883cffb6f7c92047d534fbe8 /pkgs/applications
parent602a492bb740f10f5abf99f5e42f189bddcef8b7 (diff)
downloadnixlib-fe53a6c17c0d6388748b593b8513b9c8cfbaf4de.tar
nixlib-fe53a6c17c0d6388748b593b8513b9c8cfbaf4de.tar.gz
nixlib-fe53a6c17c0d6388748b593b8513b9c8cfbaf4de.tar.bz2
nixlib-fe53a6c17c0d6388748b593b8513b9c8cfbaf4de.tar.lz
nixlib-fe53a6c17c0d6388748b593b8513b9c8cfbaf4de.tar.xz
nixlib-fe53a6c17c0d6388748b593b8513b9c8cfbaf4de.tar.zst
nixlib-fe53a6c17c0d6388748b593b8513b9c8cfbaf4de.zip
rssguard: init at 3.4.0
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/feedreaders/rssguard/default.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/pkgs/applications/networking/feedreaders/rssguard/default.nix b/pkgs/applications/networking/feedreaders/rssguard/default.nix
new file mode 100644
index 000000000000..0c17485b27b3
--- /dev/null
+++ b/pkgs/applications/networking/feedreaders/rssguard/default.nix
@@ -0,0 +1,37 @@
+{ stdenv, fetchFromGitHub, qmakeHook, qtwebengine, qttools }:
+
+stdenv.mkDerivation rec {
+  name = "rssguard-${version}";
+  version = "3.4.0";
+
+  src = fetchFromGitHub {
+    owner = "martinrotter";
+    repo = "rssguard";
+    # fetchFromGitHub doesn't support rev being a tag when fetchSubmodules=true,
+    # so need to use the hash commit. See:
+    # https://github.com/NixOS/nixpkgs/issues/26302
+    #rev = "${version}";
+    rev = "cb15ba92c9bc1b80e2b81d7976438e562ee1ef90";
+    sha256 = "1cdpfjj2lm1q2qh0w0mh505blcmi4n78458d3z3c1zn9ls9b9zsp";
+    fetchSubmodules = true;
+  };
+
+  buildInputs =  [ qmakeHook qtwebengine qttools ];
+
+  preConfigure = ''
+    qmakeFlags="$qmakeFlags CONFIG+=release"
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Simple RSS/Atom feed reader with online synchronization";
+    longDescription = ''
+      RSS Guard is a simple, light and easy-to-use RSS/ATOM feed aggregator
+      developed using Qt framework and with online feed synchronization support
+      for ownCloud/Nextcloud.
+    '';
+    homepage = https://github.com/martinrotter/rssguard;
+    license = licenses.gpl3;
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ jluttine ];
+  };
+}