summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorArie Middelkoop <amiddelk@gmail.com>2012-01-24 22:09:17 +0000
committerArie Middelkoop <amiddelk@gmail.com>2012-01-24 22:09:17 +0000
commitf9fabb462657dba73ff8c2d39c03d923eb2f4dc4 (patch)
tree71be979f85ba606ec4e53dd8256adb5be4c99079 /pkgs/applications
parent3226f48b1722a9a5ccec5129fc63eb5e2c0f26c6 (diff)
downloadnixlib-f9fabb462657dba73ff8c2d39c03d923eb2f4dc4.tar
nixlib-f9fabb462657dba73ff8c2d39c03d923eb2f4dc4.tar.gz
nixlib-f9fabb462657dba73ff8c2d39c03d923eb2f4dc4.tar.bz2
nixlib-f9fabb462657dba73ff8c2d39c03d923eb2f4dc4.tar.lz
nixlib-f9fabb462657dba73ff8c2d39c03d923eb2f4dc4.tar.xz
nixlib-f9fabb462657dba73ff8c2d39c03d923eb2f4dc4.tar.zst
nixlib-f9fabb462657dba73ff8c2d39c03d923eb2f4dc4.zip
added kwooty: a binary newsreader (kde).
svn path=/nixpkgs/trunk/; revision=31829
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/newsreaders/kwooty/default.nix38
-rw-r--r--pkgs/applications/networking/newsreaders/kwooty/searchPath.patch19
2 files changed, 57 insertions, 0 deletions
diff --git a/pkgs/applications/networking/newsreaders/kwooty/default.nix b/pkgs/applications/networking/newsreaders/kwooty/default.nix
new file mode 100644
index 000000000000..4d68191c6f21
--- /dev/null
+++ b/pkgs/applications/networking/newsreaders/kwooty/default.nix
@@ -0,0 +1,38 @@
+{ stdenv, fetchurl, gcc, cmake, qt4, gettext
+, kdelibs, kdebase_workspace, perl
+, openssl, phonon, automoc4
+, libX11, libXext, libXft
+, unrar, p7zip, par2cmdline, coreutils
+}:
+
+let version = "0.8.0";
+    name = "kwooty-${version}";
+in stdenv.mkDerivation {
+  inherit name;
+  
+  src = fetchurl {
+    url = "mirror://sourceforge/kwooty/${name}.tar.gz";
+    sha256 = "bb50fb9b3d6c973f2abee62cfc11a7086900a4b676c12bf4e0a2adc170a977fc";
+  };
+
+  patches = [ ./searchPath.patch ];
+
+  postPatch = ''
+    echo "Changing paths to archive utilities to the nix store";
+    substituteInPlace "src/utility.cpp" \
+      --replace "/usr/bin/unrar" "${unrar}/bin" \
+      --replace "/usr/bin/unpar" "${par2cmdline}/bin" \
+      --replace "/usr/bin/7z" "${p7zip}/bin" \
+      --replace "/usr/bin/nice" "${coreutils}/bin/nice"
+  '';
+
+  buildInputs =
+    [ gcc perl cmake qt4 gettext automoc4 openssl
+      kdelibs kdebase_workspace phonon
+      libX11 libXext libXft
+    ];
+                  
+  meta = with stdenv.lib; {
+    description = "Binary news reader for KDE";
+  };
+}
diff --git a/pkgs/applications/networking/newsreaders/kwooty/searchPath.patch b/pkgs/applications/networking/newsreaders/kwooty/searchPath.patch
new file mode 100644
index 000000000000..602002d0173f
--- /dev/null
+++ b/pkgs/applications/networking/newsreaders/kwooty/searchPath.patch
@@ -0,0 +1,19 @@
+--- kwooty-kwooty/src/utility.cpp	2012-01-24 22:22:45.091383072 +0100
++++ kwooty-kwooty/src/utility.cpp	2012-01-24 22:29:08.526208140 +0100
+@@ -299,6 +299,7 @@
+ 
+     QString programPathName;
+     QStringList searchPathList = Settings::searchPathList();
++    searchPathList << "/usr/bin/unpar" << "/usr/bin/unrar" << "/usr/bin/7z";
+ 
+     QStringList programsWithDifferentNames = programToSearch.split(";");
+ 
+@@ -363,7 +364,7 @@
+     QStringList niceProcessArgs;
+ 
+     // look for 'nice' location :
+-    QString nicePath = KStandardDirs::findExe("nice");
++    QString nicePath = QString("/usr/bin/nice");
+     niceProcessArgs.append(nicePath);
+     niceProcessArgs.append("-n");
+