summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorRaffael Mancini <raffael@mancini.lu>2014-09-27 12:09:48 +0200
committerRaffael Mancini <raffael@mancini.lu>2014-09-27 12:09:48 +0200
commitf80e897add2a222b7bdd25618d2db470d622b29f (patch)
tree994ae4ed40438625c8078956148f9446a578928c /pkgs/applications
parent122cfdcecf7f226e4f150c581052c42b10cfb314 (diff)
parent7323d5e1289a8da957172dbdf92bb7ebf72dd963 (diff)
downloadnixlib-f80e897add2a222b7bdd25618d2db470d622b29f.tar
nixlib-f80e897add2a222b7bdd25618d2db470d622b29f.tar.gz
nixlib-f80e897add2a222b7bdd25618d2db470d622b29f.tar.bz2
nixlib-f80e897add2a222b7bdd25618d2db470d622b29f.tar.lz
nixlib-f80e897add2a222b7bdd25618d2db470d622b29f.tar.xz
nixlib-f80e897add2a222b7bdd25618d2db470d622b29f.tar.zst
nixlib-f80e897add2a222b7bdd25618d2db470d622b29f.zip
Merge branch 'master' of github.com:NixOS/nixpkgs
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/gis/saga/default.nix2
-rw-r--r--pkgs/applications/graphics/geeqie/default.nix30
-rw-r--r--pkgs/applications/misc/calibre/default.nix4
-rw-r--r--pkgs/applications/misc/vym/default.nix2
-rw-r--r--pkgs/applications/networking/browsers/dwb/default.nix6
-rw-r--r--pkgs/applications/networking/p2p/qbittorrent/default.nix10
-rw-r--r--pkgs/applications/office/abiword/default.nix29
-rw-r--r--pkgs/applications/video/mplayer/default.nix3
-rw-r--r--pkgs/applications/video/mplayer2/default.nix7
-rw-r--r--pkgs/applications/window-managers/trayer/default.nix2
10 files changed, 46 insertions, 49 deletions
diff --git a/pkgs/applications/gis/saga/default.nix b/pkgs/applications/gis/saga/default.nix
index f7ff583a2f27..a990e19dbc3f 100644
--- a/pkgs/applications/gis/saga/default.nix
+++ b/pkgs/applications/gis/saga/default.nix
@@ -17,7 +17,7 @@ stdenv.mkDerivation rec {
     description = "SAGA - System for Automated Geoscientific Analyses";
     homepage = http://www.saga-gis.org;
     license = stdenv.lib.licenses.gpl2Plus;
-    maintainer = stdenv.lib.maintainers.michelk;
+    maintainers = [ stdenv.lib.maintainers.michelk ];
     platforms = with stdenv.lib.platforms; linux;
     broken = true;
   };
diff --git a/pkgs/applications/graphics/geeqie/default.nix b/pkgs/applications/graphics/geeqie/default.nix
index de906e3d8443..6636d5fc9ecb 100644
--- a/pkgs/applications/graphics/geeqie/default.nix
+++ b/pkgs/applications/graphics/geeqie/default.nix
@@ -1,26 +1,22 @@
-{ stdenv, fetchurl, pkgconfig, gtk, libpng, exiv2, lcms
-, intltool, gettext, libchamplain_0_6, fbida }:
+{ stdenv, fetchurl, pkgconfig, autoconf, automake, gtk, libpng, exiv2, lcms
+, intltool, gettext, libchamplain, fbida }:
 
 stdenv.mkDerivation rec {
-  name = "geeqie-1.1";
+  name = "geeqie-${version}";
+  version = "1.2";
 
   src = fetchurl {
-    url = "mirror://sourceforge/geeqie/${name}.tar.gz";
-    sha256 = "1kzy39z9505xkayyx7rjj2wda76xy3ch1s5z35zn8yli54ffhi2m";
+    url = "https://gitorious.org/geeqie/geeqie/archive/v${version}.tar.gz";
+    sha256 = "13sgf20h0z8dz1075vmyh8vbxgchq30cqrl15zfv9h8hp271vpfj";
   };
 
-  preConfigure =
-    # XXX: Trick to have Geeqie use the version we have.
-    '' sed -i "configure" \
-           -e 's/champlain-0.4/champlain-0.6/g ;
-               s/champlain-gtk-0.4/champlain-gtk-0.6/g'
-    '';
+  preConfigure = "./autogen.sh";
 
   configureFlags = [ "--enable-gps" ];
 
   buildInputs =
-    [ pkgconfig gtk libpng exiv2 lcms intltool gettext
-      libchamplain_0_6
+    [ pkgconfig autoconf automake gtk libpng exiv2 lcms intltool gettext
+      libchamplain
     ];
 
   postInstall =
@@ -31,7 +27,7 @@ stdenv.mkDerivation rec {
           -e '1 a export PATH=${exiv2}/bin:${fbida}/bin:$PATH'
     '';
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "Lightweight GTK+ based image viewer";
 
     longDescription =
@@ -45,11 +41,11 @@ stdenv.mkDerivation rec {
         initially based on GQview.
       '';
 
-    license = stdenv.lib.licenses.gpl2Plus;
+    license = licenses.gpl2Plus;
 
     homepage = http://geeqie.sourceforge.net;
 
-    maintainers = [ ];
-    platforms = stdenv.lib.platforms.gnu;
+    maintainers = with maintainers; [ pSub ];
+    platforms = platforms.gnu;
   };
 }
diff --git a/pkgs/applications/misc/calibre/default.nix b/pkgs/applications/misc/calibre/default.nix
index 1426fb8e3d71..3880ba0165e9 100644
--- a/pkgs/applications/misc/calibre/default.nix
+++ b/pkgs/applications/misc/calibre/default.nix
@@ -5,11 +5,11 @@
 }:
 
 stdenv.mkDerivation rec {
-  name = "calibre-2.3.0";
+  name = "calibre-2.4.0";
 
   src = fetchurl {
     url = "mirror://sourceforge/calibre/${name}.tar.xz";
-    sha256 = "13ny8d569hl7yv8m89216fmg0qdqqy6l9vgzf3cmbbb8i3l1lpxf";
+    sha256 = "0rgfq7178mlaf6scpm1zvn2vsfls55rdb8apwbmskmnw5wk1q6hq";
   };
 
   inherit python;
diff --git a/pkgs/applications/misc/vym/default.nix b/pkgs/applications/misc/vym/default.nix
index f53d3012b1e6..b1cfbd5d9ac4 100644
--- a/pkgs/applications/misc/vym/default.nix
+++ b/pkgs/applications/misc/vym/default.nix
@@ -29,7 +29,7 @@ stdenv.mkDerivation rec {
     '';
     homepage = http://www.insilmaril.de/vym/;
     license = licenses.gpl2;
-    maintainer = [ maintainers.AndersonTorres ];
+    maintainers = [ maintainers.AndersonTorres ];
     platforms = platforms.linux;
   };
 }
diff --git a/pkgs/applications/networking/browsers/dwb/default.nix b/pkgs/applications/networking/browsers/dwb/default.nix
index ecb57d6fe6ca..73f8be7d93dc 100644
--- a/pkgs/applications/networking/browsers/dwb/default.nix
+++ b/pkgs/applications/networking/browsers/dwb/default.nix
@@ -2,12 +2,12 @@
   m4, glib_networking, gsettings_desktop_schemas, dconf }:
 
 stdenv.mkDerivation {
-  name = "dwb-2014-07-03";
+  name = "dwb-2014-09-20";
 
   src = fetchgit {
     url = "https://bitbucket.org/portix/dwb.git";
-    rev = "6224470489eb5ba92987e01396269f8b7cd78ada";
-    sha256 = "04p9frsnh1qz067cw36anvr41an789fba839svdjrdva0f2751g8";
+    rev = "6a0e483533021157fa83ce7533c1b25c71254f00";
+    sha256 = "0l8ryz4aqcw6ax6w7y22yl9bh8fs3gxnlppbas1jq7q7hjk1qs31";
   };
 
   buildInputs = [ pkgconfig makeWrapper gsettings_desktop_schemas libsoup webkitgtk2 gtk2 gnutls json_c m4 ];
diff --git a/pkgs/applications/networking/p2p/qbittorrent/default.nix b/pkgs/applications/networking/p2p/qbittorrent/default.nix
index 0ba160c8a917..b896cc8e05bc 100644
--- a/pkgs/applications/networking/p2p/qbittorrent/default.nix
+++ b/pkgs/applications/networking/p2p/qbittorrent/default.nix
@@ -2,11 +2,11 @@
 , pkgconfig }:
 
 stdenv.mkDerivation rec {
-  name = "qbittorrent-3.1.3";
+  name = "qbittorrent-3.1.10";
 
   src = fetchurl {
     url = "mirror://sourceforge/qbittorrent/${name}.tar.xz";
-    sha256 = "16m3l8qjcj63brzrdn82cbijvz8fcxfgpibi4g5g6sbissjkwsww";
+    sha256 = "0xhqli191r5v9b5x6wj1wsjlj6svf6ldgzl7jza39q3ipr5c2pg6";
   };
 
   buildInputs = [ qt4 which dbus_libs boost libtorrentRasterbar
@@ -17,9 +17,11 @@ stdenv.mkDerivation rec {
 
   enableParallelBuilding = true;
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "Free Software alternative to µtorrent";
     homepage = http://www.qbittorrent.org/;
-    maintainers = with stdenv.lib.maintainers; [ viric ];
+    license = licenses.gpl2;
+    maintainers = with maintainers; [ viric ];
+    platforms = platforms.linux;
   };
 }
diff --git a/pkgs/applications/office/abiword/default.nix b/pkgs/applications/office/abiword/default.nix
index d9b3627507eb..43b8f1f01157 100644
--- a/pkgs/applications/office/abiword/default.nix
+++ b/pkgs/applications/office/abiword/default.nix
@@ -1,30 +1,22 @@
-{ stdenv, fetchurl, pkgconfig, gtk, libglade, libgnomecanvas, fribidi
-, libpng, popt, libgsf, enchant, wv, librsvg, bzip2, libjpeg
+{ stdenv, fetchurl, pkgconfig, gtk3, libglade, libgnomecanvas, fribidi
+, libpng, popt, libgsf, enchant, wv, librsvg, bzip2, libjpeg, perl
+, boost, libxslt
 }:
 
-stdenv.mkDerivation {
-  name = "abiword-2.8.6";
+stdenv.mkDerivation rec {
+  name = "abiword-${version}";
+  version = "3.0.0";
 
   src = fetchurl {
-    url = http://www.abisource.org/downloads/abiword/2.8.6/source/abiword-2.8.6.tar.gz;
-    sha256 = "059sd2apxdmcacc4pll880i7vm18h0kyjsq299m1mz3c7ak8k46r";
+    url = "http://www.abisource.org/downloads/abiword/${version}/source/${name}.tar.gz";
+    sha256 = "00dc3w48k2z3l1hh5b0jhzfrskqxic4lp6g7w19v6kpz02632zni";
   };
 
-  prePatch = ''
-    sed -i -e '/#include <glib\/gerror.h>/d' src/af/util/xp/ut_go_file.h
-    sed -i -e 's|#include <glib/gmacros.h>|#include <glib.h>|' \
-      goffice-bits/goffice/app/goffice-app.h
-    sed -i -e 's/ptr->jmpbuf/jmpbuf(png_ptr)/' src/af/util/xp/ut_png.cpp
-    sed -i -e 's/\(m_pPNG\)->\(jmpbuf\)/png_\2(\1)/' \
-      src/wp/impexp/gtk/ie_impGraphic_GdkPixbuf.cpp
-    sed -i -e 's/--no-undefined //' src/Makefile*
-  '';
-
   enableParallelBuilding = true;
 
   buildInputs =
-    [ pkgconfig gtk libglade librsvg bzip2 libgnomecanvas fribidi libpng popt
-      libgsf enchant wv libjpeg
+    [ pkgconfig gtk3 libglade librsvg bzip2 libgnomecanvas fribidi libpng popt
+      libgsf enchant wv libjpeg perl boost libxslt
     ];
 
   meta = with stdenv.lib; {
@@ -32,5 +24,6 @@ stdenv.mkDerivation {
     homepage = http://www.abisource.com/;
     license = licenses.gpl3;
     platforms = platforms.linux;
+    maintainers = with maintainers; [ pSub ];
   };
 }
diff --git a/pkgs/applications/video/mplayer/default.nix b/pkgs/applications/video/mplayer/default.nix
index 07bcb26569e9..dec3a5fc28da 100644
--- a/pkgs/applications/video/mplayer/default.nix
+++ b/pkgs/applications/video/mplayer/default.nix
@@ -21,6 +21,7 @@
 , bs2bSupport ? false, libbs2b ? null
 # For screenshots
 , libpngSupport ? true, libpng ? null
+, libjpegSupport ? true, libjpeg ? null
 , useUnfreeCodecs ? false
 }:
 
@@ -46,6 +47,7 @@ assert jackaudioSupport -> jack2 != null;
 assert pulseSupport -> pulseaudio != null;
 assert bs2bSupport -> libbs2b != null;
 assert libpngSupport -> libpng != null;
+assert libjpegSupport -> libjpeg != null;
 
 let
 
@@ -121,6 +123,7 @@ stdenv.mkDerivation rec {
     ++ optional vdpauSupport libvdpau
     ++ optional speexSupport speex
     ++ optional libpngSupport libpng
+    ++ optional libjpegSupport libjpeg
     ++ optional bs2bSupport libbs2b
     ;
 
diff --git a/pkgs/applications/video/mplayer2/default.nix b/pkgs/applications/video/mplayer2/default.nix
index d8ada6372b10..5827e22ea5e0 100644
--- a/pkgs/applications/video/mplayer2/default.nix
+++ b/pkgs/applications/video/mplayer2/default.nix
@@ -15,6 +15,7 @@
 , bs2bSupport ? false, libbs2b ? null
 # For screenshots
 , libpngSupport ? true, libpng ? null
+, libjpegSupport ? true, libjpeg ? null
 , useUnfreeCodecs ? false
 }:
 
@@ -32,6 +33,7 @@ assert jackaudioSupport -> jack2 != null;
 assert pulseSupport -> pulseaudio != null;
 assert bs2bSupport -> libbs2b != null;
 assert libpngSupport -> libpng != null;
+assert libjpegSupport -> libjpeg != null;
 
 let
 
@@ -96,6 +98,7 @@ stdenv.mkDerivation rec {
     ++ optional speexSupport speex
     ++ optional bs2bSupport libbs2b
     ++ optional libpngSupport libpng
+    ++ optional libjpegSupport libjpeg
     ;
 
   nativeBuildInputs = [ yasm python3 ];
@@ -110,8 +113,8 @@ stdenv.mkDerivation rec {
       ${optionalString (stdenv.isi686 || stdenv.isx86_64) "--enable-runtime-cpudetection"}
       ${optionalString dvdnavSupport "--extra-ldflags=-ldvdread"}
       ${if xvSupport then "--enable-xv" else "--disable-xv"}
-      ${if x11Support then "--enable-x11 --enable-gl --extra-cflags=-I{libx11}/include"
-		else "--disable-x11 --disable-gl"}
+      ${if x11Support then "--enable-x11 --enable-gl --extra-cflags=-I${libX11}/include"
+        else "--disable-x11 --disable-gl"}
       --disable-xvid
       --disable-ossaudio
     '';
diff --git a/pkgs/applications/window-managers/trayer/default.nix b/pkgs/applications/window-managers/trayer/default.nix
index 43a1d2b8e79a..b7f1d9adad12 100644
--- a/pkgs/applications/window-managers/trayer/default.nix
+++ b/pkgs/applications/window-managers/trayer/default.nix
@@ -19,7 +19,7 @@ stdenv.mkDerivation rec {
     license = licenses.mit;
     description = "A lightweight GTK2-based systray for UNIX desktop";
     platforms = platforms.linux;
-    maintainer = with maintainers; [ pSub ];
+    maintainers = with maintainers; [ pSub ];
   };
 }