summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorFranz Pletz <fpletz@fnordicwalking.de>2016-09-04 00:30:38 +0200
committerGitHub <noreply@github.com>2016-09-04 00:30:38 +0200
commitecdfa4109e1a61e4b54daf38536ed62c7ebee3d7 (patch)
treea14c9099a97f3f055db3838f7c7325e32ac8ce81 /pkgs/applications
parent8a96c52f637f7a85a3222c036b87ea0d81d47a14 (diff)
parent7a5239fddc4dd8461179e9d272efd0aa7e1576fc (diff)
downloadnixlib-ecdfa4109e1a61e4b54daf38536ed62c7ebee3d7.tar
nixlib-ecdfa4109e1a61e4b54daf38536ed62c7ebee3d7.tar.gz
nixlib-ecdfa4109e1a61e4b54daf38536ed62c7ebee3d7.tar.bz2
nixlib-ecdfa4109e1a61e4b54daf38536ed62c7ebee3d7.tar.lz
nixlib-ecdfa4109e1a61e4b54daf38536ed62c7ebee3d7.tar.xz
nixlib-ecdfa4109e1a61e4b54daf38536ed62c7ebee3d7.tar.zst
nixlib-ecdfa4109e1a61e4b54daf38536ed62c7ebee3d7.zip
Merge pull request #18098 from stesie/phpstorm-2016.2.1
idea.phpstorm: 10.0.4 -> 2016.2.1
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/idea/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/pkgs/applications/editors/idea/default.nix b/pkgs/applications/editors/idea/default.nix
index 06573f22a1a5..732ad1ba88f9 100644
--- a/pkgs/applications/editors/idea/default.nix
+++ b/pkgs/applications/editors/idea/default.nix
@@ -228,6 +228,18 @@ in
 
   phpstorm = buildPhpStorm rec {
     name = "phpstorm-${version}";
+    version = "2016.2.1";
+    description = "Professional IDE for Web and PHP developers";
+    license = stdenv.lib.licenses.unfree;
+    src = fetchurl {
+      url = "https://download.jetbrains.com/webide/PhpStorm-${version}.tar.gz";
+      sha256 = "0vgr0ds6z0y8qw2v55nr3pi5zb5x0n6pxm13hcp44iradns5kmbp";
+    };
+    wmClass = "jetbrains-phpstorm";
+  };
+
+  phpstorm10 = buildPhpStorm rec {
+    name = "phpstorm-${version}";
     version = "10.0.4";
     description = "Professional IDE for Web and PHP developers";
     license = stdenv.lib.licenses.unfree;
@@ -238,6 +250,7 @@ in
     wmClass = "jetbrains-phpstorm";
   };
 
+
   webstorm = buildWebStorm rec {
     name = "webstorm-${version}";
     version = "10.0.5";