summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorAndreas Rammhold <andreas@rammhold.de>2018-02-07 22:15:50 +0100
committerAndreas Rammhold <andreas@rammhold.de>2018-02-07 22:22:53 +0100
commite90985e92a9e8d1e32109befb5bf4f25b4de1369 (patch)
tree08848b7347b173245e5c40cf3553400867e46f96 /pkgs/applications
parent0d65e2e0e5b318614bf967c71308355939d9aaaf (diff)
downloadnixlib-e90985e92a9e8d1e32109befb5bf4f25b4de1369.tar
nixlib-e90985e92a9e8d1e32109befb5bf4f25b4de1369.tar.gz
nixlib-e90985e92a9e8d1e32109befb5bf4f25b4de1369.tar.bz2
nixlib-e90985e92a9e8d1e32109befb5bf4f25b4de1369.tar.lz
nixlib-e90985e92a9e8d1e32109befb5bf4f25b4de1369.tar.xz
nixlib-e90985e92a9e8d1e32109befb5bf4f25b4de1369.tar.zst
nixlib-e90985e92a9e8d1e32109befb5bf4f25b4de1369.zip
gitAndTools.grv: 0.1.1 -> 0.1.2
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/version-management/git-and-tools/grv/default.nix7
-rw-r--r--pkgs/applications/version-management/git-and-tools/grv/deps.nix102
2 files changed, 3 insertions, 106 deletions
diff --git a/pkgs/applications/version-management/git-and-tools/grv/default.nix b/pkgs/applications/version-management/git-and-tools/grv/default.nix
index cbcf4cd9aeb7..dc111b294503 100644
--- a/pkgs/applications/version-management/git-and-tools/grv/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/grv/default.nix
@@ -1,6 +1,6 @@
 { stdenv, buildGoPackage, fetchFromGitHub, curl, libgit2_0_25, ncurses, pkgconfig, readline }:
 let
-  version = "0.1.1";
+  version = "0.1.2";
 in
 buildGoPackage {
   name = "grv-${version}";
@@ -10,13 +10,12 @@ buildGoPackage {
 
   goPackagePath = "github.com/rgburke/grv";
 
-  goDeps = ./deps.nix;
-
   src = fetchFromGitHub {
     owner = "rgburke";
     repo = "grv";
     rev = "v${version}";
-    sha256 = "0q9gvxfw48d4kjpb2jx7lg577vazjg0n961y6ija5saja5n16mk2";
+    sha256 = "1i8cr5xxdacpby60nqfyj8ijyc0h62029kbds2lq26rb8nn9qih2";
+    fetchSubmodules = true;
   };
 
   meta = with stdenv.lib; {
diff --git a/pkgs/applications/version-management/git-and-tools/grv/deps.nix b/pkgs/applications/version-management/git-and-tools/grv/deps.nix
deleted file mode 100644
index 8de555df2e8f..000000000000
--- a/pkgs/applications/version-management/git-and-tools/grv/deps.nix
+++ /dev/null
@@ -1,102 +0,0 @@
-# This file was generated by https://github.com/kamilchm/go2nix v1.2.1
-[
-  {
-    goPackagePath = "github.com/Sirupsen/logrus";
-    fetch = {
-      type = "git";
-      url = "https://github.com/Sirupsen/logrus";
-      rev = "768a92a02685ee7535069fc1581341b41bab9b72";
-      sha256 = "1m67cxb6p0zgq0xba63qb4vvy6z5d78alya0vnx5djfixygiij53";
-    };
-  }
-  {
-    goPackagePath = "github.com/bradfitz/slice";
-    fetch = {
-      type = "git";
-      url = "https://github.com/bradfitz/slice";
-      rev = "d9036e2120b5ddfa53f3ebccd618c4af275f47da";
-      sha256 = "189h48w3ppvx2kqyxq0s55kxv629lljjxbyqjnlrgg8fy6ya8wgy";
-    };
-  }
-  {
-    goPackagePath = "github.com/gobwas/glob";
-    fetch = {
-      type = "git";
-      url = "https://github.com/gobwas/glob";
-      rev = "51eb1ee00b6d931c66d229ceeb7c31b985563420";
-      sha256 = "090wzpwsjana1qas8ipwh1pj959gvc4b7vwybzi01f3bmd79jwlp";
-    };
-  }
-  {
-    goPackagePath = "github.com/mattn/go-runewidth";
-    fetch = {
-      type = "git";
-      url = "https://github.com/mattn/go-runewidth";
-      rev = "97311d9f7767e3d6f422ea06661bc2c7a19e8a5d";
-      sha256 = "0dxlrzn570xl7gb11hjy1v4p3gw3r41yvqhrffgw95ha3q9p50cg";
-    };
-  }
-  {
-    goPackagePath = "github.com/rgburke/goncurses";
-    fetch = {
-      type = "git";
-      url = "https://github.com/rgburke/goncurses";
-      rev = "9a788ac9d81e61c6a2ca6205ee8d72d738ed12b9";
-      sha256 = "0xqwxscdszbybriyzqmsd2zkzda9anckx56q8gksfy3gwj286gpb";
-    };
-  }
-  {
-    goPackagePath = "github.com/rjeczalik/notify";
-    fetch = {
-      type = "git";
-      url = "https://github.com/rjeczalik/notify";
-      rev = "27b537f07230b3f917421af6dcf044038dbe57e2";
-      sha256 = "05alsqjz2x8jzz2yp8r20zwglcg7y1ywq60zy6icj18qs3abmlp0";
-    };
-  }
-  {
-    goPackagePath = "github.com/tchap/go-patricia";
-    fetch = {
-      type = "git";
-      url = "https://github.com/tchap/go-patricia";
-      rev = "5ad6cdb7538b0097d5598c7e57f0a24072adf7dc";
-      sha256 = "0351x63zqympgfsnjl78cgvqhvipl3kfs1i15hfaw91hqin6dykr";
-    };
-  }
-  {
-    goPackagePath = "go4.org";
-    fetch = {
-      type = "git";
-      url = "https://github.com/camlistore/go4";
-      rev = "fba789b7e39ba524b9e60c45c37a50fae63a2a09";
-      sha256 = "01irxqy8na646b4zbw7v3zwy3yx9m7flhim5c3z4lzq5hiy2h75i";
-    };
-  }
-  {
-    goPackagePath = "golang.org/x/crypto";
-    fetch = {
-      type = "git";
-      url = "https://go.googlesource.com/crypto";
-      rev = "1875d0a70c90e57f11972aefd42276df65e895b9";
-      sha256 = "1kprrdzr4i4biqn7r9gfxzsmijya06i9838skprvincdb1pm0q2q";
-    };
-  }
-  {
-    goPackagePath = "golang.org/x/sys";
-    fetch = {
-      type = "git";
-      url = "https://go.googlesource.com/sys";
-      rev = "3dbebcf8efb6a5011a60c2b4591c1022a759af8a";
-      sha256 = "02pwjyimpm13km3fk0rg2l9p37w7qycdwp74piawwgcgh80qnww9";
-    };
-  }
-  {
-    goPackagePath = "gopkg.in/libgit2/git2go.v25";
-    fetch = {
-      type = "git";
-      url = "https://gopkg.in/libgit2/git2go.v25";
-      rev = "334260d743d713a55ff3c097ec6707f2bb39e9d5";
-      sha256 = "0hfya9z2pg29zbc0s92hj241rnbk7d90jzj34q0dp8b7akz6r1rc";
-    };
-  }
-]