summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorvbgl <vbgl@users.noreply.github.com>2014-12-25 23:32:51 +0100
committervbgl <vbgl@users.noreply.github.com>2014-12-25 23:32:51 +0100
commite553cbee5a6582b24d6ad0eb7059364f6f2c0726 (patch)
tree4d3bd9504c7b7d67b583f5425a40cb4e4821f685 /pkgs/applications
parent1c8783f39b4110c7b965ccf819ed9a310cc92669 (diff)
parentbc5938b07d744af76b014fda359de0685b7e2115 (diff)
downloadnixlib-e553cbee5a6582b24d6ad0eb7059364f6f2c0726.tar
nixlib-e553cbee5a6582b24d6ad0eb7059364f6f2c0726.tar.gz
nixlib-e553cbee5a6582b24d6ad0eb7059364f6f2c0726.tar.bz2
nixlib-e553cbee5a6582b24d6ad0eb7059364f6f2c0726.tar.lz
nixlib-e553cbee5a6582b24d6ad0eb7059364f6f2c0726.tar.xz
nixlib-e553cbee5a6582b24d6ad0eb7059364f6f2c0726.tar.zst
nixlib-e553cbee5a6582b24d6ad0eb7059364f6f2c0726.zip
Merge pull request #5446 from nckx/remotebox-squashed
Add RemoteBox, a (you guessed it) remote VirtualBox client
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/virtualization/remotebox/default.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/pkgs/applications/virtualization/remotebox/default.nix b/pkgs/applications/virtualization/remotebox/default.nix
new file mode 100644
index 000000000000..a257ef27e9fd
--- /dev/null
+++ b/pkgs/applications/virtualization/remotebox/default.nix
@@ -0,0 +1,40 @@
+{ stdenv, fetchurl, perl, perlPackages }:
+
+stdenv.mkDerivation rec {
+  version = "1.9";
+  name = "remotebox-${version}";
+
+  src = fetchurl {
+    url = "${meta.homepage}/downloads/RemoteBox-${version}.tar.bz2";
+    sha256 = "0vsfz2qmha9nz60fyksgqqyrw4lz9z2d5isnwqc6afn8z3i1qmkp";
+  };
+
+  buildInputs = [ perl perlPackages.Gtk2 perlPackages.SOAPLite ];
+
+  installPhase = ''
+    mkdir -p $out/bin
+    cp -a docs/ share/ $out
+
+    substituteInPlace remotebox --replace "\$Bin/" "\$Bin/../"
+    install -t $out/bin remotebox
+
+    mkdir -p $out/share/applications
+    cp -p packagers-readme/*.desktop $out/share/applications
+  '';
+
+  meta = with stdenv.lib; {
+    description = "VirtualBox client with remote management";
+    homepage = http://remotebox.knobgoblin.org.uk/;
+    license = with licenses; gpl2Plus;
+    longDescription = ''
+      VirtualBox is traditionally considered to be a virtualization solution
+      aimed at the desktop.  While it is certainly possible to install
+      VirtualBox on a server, it offers few remote management features beyond
+      using the vboxmanage command line.
+      RemoteBox aims to fill this gap by providing a graphical VirtualBox
+      client which is able to manage a VirtualBox server installation.
+    '';
+    maintainers = with maintainers; [ nckx ];
+    platforms = with platforms; all;
+  };
+}