summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorvolth <volth@volth.com>2018-07-14 15:00:02 +0000
committerGitHub <noreply@github.com>2018-07-14 15:00:02 +0000
commite3d6f6f202742777e527b55390598ee403b44028 (patch)
treebb77d262b2828a37feaa74c0ac2b462ffdf4856f /pkgs/applications
parentd4f63206d8a3041356df0f65f49c1ea61be04eba (diff)
downloadnixlib-e3d6f6f202742777e527b55390598ee403b44028.tar
nixlib-e3d6f6f202742777e527b55390598ee403b44028.tar.gz
nixlib-e3d6f6f202742777e527b55390598ee403b44028.tar.bz2
nixlib-e3d6f6f202742777e527b55390598ee403b44028.tar.lz
nixlib-e3d6f6f202742777e527b55390598ee403b44028.tar.xz
nixlib-e3d6f6f202742777e527b55390598ee403b44028.tar.zst
nixlib-e3d6f6f202742777e527b55390598ee403b44028.zip
processing3: fix crash under XFCE
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/graphics/processing3/default.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/pkgs/applications/graphics/processing3/default.nix b/pkgs/applications/graphics/processing3/default.nix
index 4ef078fdbac6..87566950bfe5 100644
--- a/pkgs/applications/graphics/processing3/default.nix
+++ b/pkgs/applications/graphics/processing3/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, callPackage, fetchFromGitHub, makeWrapper, ant, jdk, rsync, javaPackages, libXxf86vm }:
+{ stdenv, callPackage, fetchFromGitHub, makeWrapper, ant, jdk, rsync, javaPackages, libXxf86vm, gsettings-desktop-schemas }:
 
 stdenv.mkDerivation rec {
   version = "3.3.7";
@@ -37,9 +37,11 @@ stdenv.mkDerivation rec {
     ln -s ${jdk} $out/${name}/java
 
     makeWrapper $out/${name}/processing      $out/bin/processing \
+        --prefix XDG_DATA_DIRS : ${gsettings-desktop-schemas}/share/gsettings-schemas/${gsettings-desktop-schemas.name} \
         --prefix _JAVA_OPTIONS " " -Dawt.useSystemAAFontSettings=lcd \
         --prefix LD_LIBRARY_PATH : ${libXxf86vm}/lib
     makeWrapper $out/${name}/processing-java $out/bin/processing-java \
+        --prefix XDG_DATA_DIRS : ${gsettings-desktop-schemas}/share/gsettings-schemas/${gsettings-desktop-schemas.name} \
         --prefix _JAVA_OPTIONS " " -Dawt.useSystemAAFontSettings=lcd \
         --prefix LD_LIBRARY_PATH : ${libXxf86vm}/lib
   '';