summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorYegor Timoshenko <yegortimoshenko@riseup.net>2018-10-16 11:31:36 +0000
committerGitHub <noreply@github.com>2018-10-16 11:31:36 +0000
commite31942c71eef88a7188acc36b00c2a916d8774e6 (patch)
tree59e1df4827c7081e9cc90d23b515103210d43199 /pkgs/applications
parenta65f0b3d55d9b33086d258a6b563ccb4fd4ac6f2 (diff)
parent02602b2c15eaccf80490168591cf289ac81cc9d5 (diff)
downloadnixlib-e31942c71eef88a7188acc36b00c2a916d8774e6.tar
nixlib-e31942c71eef88a7188acc36b00c2a916d8774e6.tar.gz
nixlib-e31942c71eef88a7188acc36b00c2a916d8774e6.tar.bz2
nixlib-e31942c71eef88a7188acc36b00c2a916d8774e6.tar.lz
nixlib-e31942c71eef88a7188acc36b00c2a916d8774e6.tar.xz
nixlib-e31942c71eef88a7188acc36b00c2a916d8774e6.tar.zst
nixlib-e31942c71eef88a7188acc36b00c2a916d8774e6.zip
Merge pull request #48282 from transumption/201810/qemu-smartcard
qemu: enable smartcard support
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/virtualization/qemu/default.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/pkgs/applications/virtualization/qemu/default.nix b/pkgs/applications/virtualization/qemu/default.nix
index 596bc9dd9e09..d9495bd984ef 100644
--- a/pkgs/applications/virtualization/qemu/default.nix
+++ b/pkgs/applications/virtualization/qemu/default.nix
@@ -10,6 +10,7 @@
 , sdlSupport ? !stdenv.isDarwin, SDL2
 , gtkSupport ? !stdenv.isDarwin && !xenSupport, gtk3, gettext, gnome3
 , vncSupport ? true, libjpeg, libpng
+, smartcardSupport ? true, libcacard
 , spiceSupport ? !stdenv.isDarwin, spice, spice-protocol
 , usbredirSupport ? spiceSupport, usbredir
 , xenSupport ? false, xen
@@ -58,6 +59,7 @@ stdenv.mkDerivation rec {
     ++ optionals sdlSupport [ SDL2 ]
     ++ optionals gtkSupport [ gtk3 gettext gnome3.vte ]
     ++ optionals vncSupport [ libjpeg libpng ]
+    ++ optionals smartcardSupport [ libcacard ]
     ++ optionals spiceSupport [ spice-protocol spice ]
     ++ optionals usbredirSupport [ usbredir ]
     ++ optionals stdenv.isLinux [ alsaLib libaio libcap_ng libcap attr ]
@@ -108,6 +110,7 @@ stdenv.mkDerivation rec {
     ++ optional stdenv.isDarwin "--cpu=x86_64"
     ++ optional numaSupport "--enable-numa"
     ++ optional seccompSupport "--enable-seccomp"
+    ++ optional smartcardSupport "--enable-smartcard"
     ++ optional spiceSupport "--enable-spice"
     ++ optional usbredirSupport "--enable-usb-redir"
     ++ optional hostCpuOnly "--target-list=${hostCpuTargets}"