summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorAnonymous <anon@localhost>2014-09-24 12:13:55 +0200
committerEdward Tjörnhammar <ed@cflags.cc>2014-09-24 12:13:55 +0200
commite223bc046cb899d5b72bc18a9b3a99c7175e4912 (patch)
tree9f86df7878d4a8191be65661f182b399856917b1 /pkgs/applications
parenta3b565f7a302a615069e6ee90ba026cab2383ae8 (diff)
downloadnixlib-e223bc046cb899d5b72bc18a9b3a99c7175e4912.tar
nixlib-e223bc046cb899d5b72bc18a9b3a99c7175e4912.tar.gz
nixlib-e223bc046cb899d5b72bc18a9b3a99c7175e4912.tar.bz2
nixlib-e223bc046cb899d5b72bc18a9b3a99c7175e4912.tar.lz
nixlib-e223bc046cb899d5b72bc18a9b3a99c7175e4912.tar.xz
nixlib-e223bc046cb899d5b72bc18a9b3a99c7175e4912.tar.zst
nixlib-e223bc046cb899d5b72bc18a9b3a99c7175e4912.zip
android-studio: new package
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/idea/default.nix35
1 files changed, 33 insertions, 2 deletions
diff --git a/pkgs/applications/editors/idea/default.nix b/pkgs/applications/editors/idea/default.nix
index 5727cd12dc77..f67f23e9e09b 100644
--- a/pkgs/applications/editors/idea/default.nix
+++ b/pkgs/applications/editors/idea/default.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchurl, makeDesktopItem, makeWrapper, patchelf, p7zip, jdk
-, coreutils, gnugrep, which, git, python
+, coreutils, gnugrep, which, git, python, unzip
 }:
 
 assert stdenv.isLinux;
@@ -24,7 +24,7 @@ let
       icon = loName;
     };
 
-    buildInputs = [ makeWrapper patchelf p7zip ];
+    buildInputs = [ makeWrapper patchelf p7zip unzip ];
 
     patchPhase = ''
 
@@ -79,6 +79,24 @@ let
 
   };
 
+  buildAndroidStudio = { name, version, build, src, license, description }:
+    (mkIdeaProduct rec {
+      inherit name version build src;
+      product = "Studio";
+      meta = with stdenv.lib; {
+        homepage = https://developer.android.com/sdk/installing/studio.html;
+        inherit description license;
+        longDescription = ''
+          Android development environment based on IntelliJ
+          IDEA providing new features and improvements over
+          Eclipse ADT and will be the official Android IDE
+          once it's ready.
+        '';
+        platforms = platforms.linux;
+        maintainers = with maintainers; [ edwtjo ];
+      };
+    });
+
   buildPycharm = { name, version, build, src, license, description }:
     (mkIdeaProduct rec {
       inherit name version build src;
@@ -127,6 +145,19 @@ in
 
 {
 
+  android-studio = buildAndroidStudio rec {
+    name = "android-studio-${version}";
+    version = "0.8.10";
+    build = "135.1428667";
+    description = "Android development environment based on IntelliJ IDEA";
+    license = stdenv.lib.licenses.asl20;
+    src = fetchurl {
+      url = "https://dl.google.com/dl/android/studio/ide-zips/${version}" +
+            "/android-studio-ide-${build}-linux.zip";
+      sha256 = "5736a92ffda24233026ff45a47f1b4f9567ba40347cfa0c9f351112e729b5401";
+    };
+  };
+
   idea-community = buildIdea rec {
     name = "idea-community-${version}";
     version = "13.1.4b";