summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2016-12-28 10:40:18 +0000
committerGitHub <noreply@github.com>2016-12-28 10:40:18 +0000
commite1b1df2bd92201028eae00f6956a1fceae0e8b54 (patch)
tree35b6ae73e21ed1db0840e1efef52ef7de2fe9e50 /pkgs/applications
parent400886f3d0960cda5ef03c5375848800df0721fb (diff)
parentb7996efeae6c3fe108ba761e79c8eeb5ebb77e51 (diff)
downloadnixlib-e1b1df2bd92201028eae00f6956a1fceae0e8b54.tar
nixlib-e1b1df2bd92201028eae00f6956a1fceae0e8b54.tar.gz
nixlib-e1b1df2bd92201028eae00f6956a1fceae0e8b54.tar.bz2
nixlib-e1b1df2bd92201028eae00f6956a1fceae0e8b54.tar.lz
nixlib-e1b1df2bd92201028eae00f6956a1fceae0e8b54.tar.xz
nixlib-e1b1df2bd92201028eae00f6956a1fceae0e8b54.tar.zst
nixlib-e1b1df2bd92201028eae00f6956a1fceae0e8b54.zip
Merge pull request #20028 from zraexy/qsyncthingtray
qsyncthingtray: init at 0.5.5rc2
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/qsyncthingtray/default.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/pkgs/applications/misc/qsyncthingtray/default.nix b/pkgs/applications/misc/qsyncthingtray/default.nix
new file mode 100644
index 000000000000..96d2aa0c85b7
--- /dev/null
+++ b/pkgs/applications/misc/qsyncthingtray/default.nix
@@ -0,0 +1,41 @@
+{ stdenv, fetchFromGitHub
+, qtbase, qtwebengine
+, qmakeHook }:
+
+stdenv.mkDerivation rec {
+  version = "0.5.5rc2";
+  name = "qsyncthingtray-${version}";
+
+  src = fetchFromGitHub {
+    owner = "sieren";
+    repo = "QSyncthingTray";
+    rev = "${version}";
+    sha256 = "1x7j7ylgm4ih06m7gb5ls3c9bdjwbra675489caq2f04kgw4yxq2";
+  };
+
+  buildInputs = [ qtbase qtwebengine ];
+  nativeBuildInputs = [ qmakeHook ];
+  enableParallelBuilding = true;
+  
+  postInstall = ''
+    mkdir -p $out/bin
+    cp binary/QSyncthingTray $out/bin
+    cat > $out/bin/qt.conf <<EOF
+    [Paths]
+    Prefix = ${qtwebengine.out}
+    EOF
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = https://github.com/sieren/QSyncthingTray/;
+    description = "A Traybar Application for Syncthing written in C++";
+    longDescription = ''
+        A cross-platform status bar for Syncthing.
+        Currently supports OS X, Windows and Linux.
+        Written in C++ with Qt.
+    '';
+    license = licenses.lgpl3;
+    maintainers = with maintainers; [ zraexy ];
+    platforms = platforms.all;
+  };
+}