summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2017-06-05 22:23:01 +0100
committerGitHub <noreply@github.com>2017-06-05 22:23:01 +0100
commitdffec16abd218ed1e1381e659ceac7c606c13262 (patch)
tree58cf46366ec141d97fc3321c7ebcc41f5da76504 /pkgs/applications
parente99e43cc4ca9870d901cfe37d4d75ff2efdf937f (diff)
parentb81124b4fb9084aa1f6cc6f7b134a27200c7c0ed (diff)
downloadnixlib-dffec16abd218ed1e1381e659ceac7c606c13262.tar
nixlib-dffec16abd218ed1e1381e659ceac7c606c13262.tar.gz
nixlib-dffec16abd218ed1e1381e659ceac7c606c13262.tar.bz2
nixlib-dffec16abd218ed1e1381e659ceac7c606c13262.tar.lz
nixlib-dffec16abd218ed1e1381e659ceac7c606c13262.tar.xz
nixlib-dffec16abd218ed1e1381e659ceac7c606c13262.tar.zst
nixlib-dffec16abd218ed1e1381e659ceac7c606c13262.zip
Merge pull request #26410 from kierdavis/hooks
Fix hooks not being called when overriding phases in various packages
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/graphics/unigine-valley/default.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/pkgs/applications/graphics/unigine-valley/default.nix b/pkgs/applications/graphics/unigine-valley/default.nix
index 1bb57538cd5f..dc896e0b0d9b 100644
--- a/pkgs/applications/graphics/unigine-valley/default.nix
+++ b/pkgs/applications/graphics/unigine-valley/default.nix
@@ -51,20 +51,30 @@ in
     ];
 
     unpackPhase = ''
+      runHook preUnpack
+
       cp $src extractor.run
       chmod +x extractor.run
       ./extractor.run --target $sourceRoot
+
+      runHook postUnpack
     '';
 
     patchPhase = ''
+      runHook prePatch
+
       # Patch ELF files.
       elfs=$(find bin -type f | xargs file | grep ELF | cut -d ':' -f 1)
       for elf in $elfs; do
         patchelf --set-interpreter ${stdenv.cc.libc}/lib/ld-linux-x86-64.so.2 $elf || true
       done
+
+      runHook postPatch
     '';
 
     installPhase = ''
+      runHook preInstall
+
       instdir=$out/${instPath}
 
       # Install executables and libraries
@@ -86,6 +96,8 @@ in
       wrapProgram $out/bin/valley \
         --run "cd $instdir" \
         --prefix LD_LIBRARY_PATH : /run/opengl-driver/lib:$instdir/bin:$libPath
+
+      runHook postInstall
     '';
 
     stripDebugList = ["${instPath}/bin"];