summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorRahul Gopinath <rahul@gopinath.org>2016-06-21 22:35:16 -0700
committerRahul Gopinath <rahul@gopinath.org>2016-06-22 09:27:32 -0700
commitdf6540dc55981a52d2b0814900131640bf91b25d (patch)
treee2e11a37424b35b4282c6fa6f6047dd314058328 /pkgs/applications
parentb02f57204d48ddd045fb6f08acd153a8f73de884 (diff)
downloadnixlib-df6540dc55981a52d2b0814900131640bf91b25d.tar
nixlib-df6540dc55981a52d2b0814900131640bf91b25d.tar.gz
nixlib-df6540dc55981a52d2b0814900131640bf91b25d.tar.bz2
nixlib-df6540dc55981a52d2b0814900131640bf91b25d.tar.lz
nixlib-df6540dc55981a52d2b0814900131640bf91b25d.tar.xz
nixlib-df6540dc55981a52d2b0814900131640bf91b25d.tar.zst
nixlib-df6540dc55981a52d2b0814900131640bf91b25d.zip
netsurf-libnsfb: init at 0.1.4
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/netsurf/libnsfb/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/pkgs/applications/misc/netsurf/libnsfb/default.nix b/pkgs/applications/misc/netsurf/libnsfb/default.nix
new file mode 100644
index 000000000000..3e2346597fa4
--- /dev/null
+++ b/pkgs/applications/misc/netsurf/libnsfb/default.nix
@@ -0,0 +1,31 @@
+{ stdenv, fetchurl, pkgconfig, ui? "gtk"
+, buildsystem
+}:
+
+stdenv.mkDerivation rec {
+
+  name = "netsurf-${libname}-${version}";
+  libname = "libnsfb";
+  version = "0.1.4";
+
+  src = fetchurl {
+    url = "http://download.netsurf-browser.org/libs/releases/${libname}-${version}-src.tar.gz";
+    sha256 = "176f8why9gzbaca9nnxjqasl02qzc6g507z5w3dzkcjifnkz4mzl";
+  };
+
+  buildInputs = [ pkgconfig buildsystem ];
+
+  makeFlags = [
+    "PREFIX=$(out)"
+    "NSSHARED=${buildsystem}/share/netsurf-buildsystem"
+    "TARGET=${ui}"
+  ];
+
+  meta = with stdenv.lib; {
+    homepage = "http://www.netsurf-browser.org/";
+    description = "CSS parser and selection library for netsurf browser";
+    license = licenses.gpl2;
+    maintainers = [ maintainers.vrthra ];
+    platforms = platforms.linux;
+  };
+}