summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authoraszlig <aszlig@nix.build>2018-05-08 11:22:28 +0200
committeraszlig <aszlig@nix.build>2018-05-08 11:48:16 +0200
commitdace4813771fa3563eda06b83d8362388ba8a96b (patch)
tree123432a9576b274b21c5006e18ea6f091f2825fa /pkgs/applications
parenteb774f30475547033d7059b1ea5de6393e3996bc (diff)
downloadnixlib-dace4813771fa3563eda06b83d8362388ba8a96b.tar
nixlib-dace4813771fa3563eda06b83d8362388ba8a96b.tar.gz
nixlib-dace4813771fa3563eda06b83d8362388ba8a96b.tar.bz2
nixlib-dace4813771fa3563eda06b83d8362388ba8a96b.tar.lz
nixlib-dace4813771fa3563eda06b83d8362388ba8a96b.tar.xz
nixlib-dace4813771fa3563eda06b83d8362388ba8a96b.tar.zst
nixlib-dace4813771fa3563eda06b83d8362388ba8a96b.zip
kdepim-addons: Add package expression
This is needed in order to add location information to contacts in
KAddressbook.

Packaging was quite straightforward except that it needed
akonadi-import-wizard, which I have packaged in the previous commit.

I'm committing this directly to master without a pull request, because
nothing depends on it (for obvious reasons) and packaging was trivial
enough so that if things are not as they supposed to be it can still be
changed very easily.

Tested this using the following VM configuration, because I don't run a
Plasma desktop:

(import <nixpkgs/nixos> {
  configuration = { pkgs, ... }: {
    environment.systemPackages = with import <nixpkgs> {}; [
      kdeApplications.kaddressbook kdeApplications.kdepim-addons
    ];
    users.users.test.isNormalUser = true;
    virtualisation.diskSize = 4096;
    virtualisation.memorySize = 2048;

    services.xserver = {
      enable = true;
      inherit ((import <nixpkgs/nixos> {}).config.services.xserver) layout;
      displayManager.sddm.enable = true;
      displayManager.sddm.autoLogin.enable = true;
      displayManager.sddm.autoLogin.user = "test";
      desktopManager.default = "plasma5";
      desktopManager.plasma5.enable = true;
    };
  };
}).vm

The test I've done is using KAddressbook and check whether the location
tab is working and it does now.

Signed-off-by: aszlig <aszlig@nix.build>
Cc: @ttuegel, @vandenoever
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/kde/default.nix1
-rw-r--r--pkgs/applications/kde/kdepim-addons.nix23
2 files changed, 24 insertions, 0 deletions
diff --git a/pkgs/applications/kde/default.nix b/pkgs/applications/kde/default.nix
index 5b21844dd184..f602e5c92d9f 100644
--- a/pkgs/applications/kde/default.nix
+++ b/pkgs/applications/kde/default.nix
@@ -102,6 +102,7 @@ let
       kdenetwork-filesharing = callPackage ./kdenetwork-filesharing.nix {};
       kdenlive = callPackage ./kdenlive.nix {};
       kdepim-runtime = callPackage ./kdepim-runtime.nix {};
+      kdepim-addons = callPackage ./kdepim-addons.nix {};
       kdepim-apps-libs = callPackage ./kdepim-apps-libs {};
       kdf = callPackage ./kdf.nix {};
       kdialog = callPackage ./kdialog.nix {};
diff --git a/pkgs/applications/kde/kdepim-addons.nix b/pkgs/applications/kde/kdepim-addons.nix
new file mode 100644
index 000000000000..fd3fe2d6c098
--- /dev/null
+++ b/pkgs/applications/kde/kdepim-addons.nix
@@ -0,0 +1,23 @@
+{
+  mkDerivation, lib, kdepimTeam,
+  extra-cmake-modules, shared-mime-info,
+  akonadi-import-wizard, akonadi-notes, calendarsupport, eventviews,
+  incidenceeditor, kcalcore, kcalutils, kconfig, kdbusaddons, kdeclarative,
+  kdepim-apps-libs, kholidays, ki18n, kmime, ktexteditor, ktnef, libgravatar,
+  libksieve, mailcommon, mailimporter, messagelib, poppler_qt5, prison
+}:
+
+mkDerivation {
+  name = "kdepim-addons";
+  meta = {
+    license = with lib.licenses; [ gpl2Plus lgpl21Plus ];
+    maintainers = kdepimTeam;
+  };
+  nativeBuildInputs = [ extra-cmake-modules shared-mime-info ];
+  buildInputs = [
+    akonadi-import-wizard akonadi-notes calendarsupport eventviews
+    incidenceeditor kcalcore kcalutils kconfig kdbusaddons kdeclarative
+    kdepim-apps-libs kholidays ki18n kmime ktexteditor ktnef libgravatar
+    libksieve mailcommon mailimporter messagelib poppler_qt5 prison
+  ];
+}