summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorAntoine R. Dumont <antoine.romain.dumont@gmail.com>2015-06-05 10:48:37 +0200
committerAntoine R. Dumont <antoine.romain.dumont@gmail.com>2015-06-06 21:02:46 +0200
commitdac5a45acf5962e4b5c07240e352fed7f09be007 (patch)
tree1c1d8f6ab81325956ac64afa7d0cc0a2c1259f8c /pkgs/applications
parentc659105ef8b2fe87822acf52f191a189f62e4d8a (diff)
downloadnixlib-dac5a45acf5962e4b5c07240e352fed7f09be007.tar
nixlib-dac5a45acf5962e4b5c07240e352fed7f09be007.tar.gz
nixlib-dac5a45acf5962e4b5c07240e352fed7f09be007.tar.bz2
nixlib-dac5a45acf5962e4b5c07240e352fed7f09be007.tar.lz
nixlib-dac5a45acf5962e4b5c07240e352fed7f09be007.tar.xz
nixlib-dac5a45acf5962e4b5c07240e352fed7f09be007.tar.zst
nixlib-dac5a45acf5962e4b5c07240e352fed7f09be007.zip
Add apvlv pdf reader
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/apvlv/default.nix48
1 files changed, 48 insertions, 0 deletions
diff --git a/pkgs/applications/misc/apvlv/default.nix b/pkgs/applications/misc/apvlv/default.nix
new file mode 100644
index 000000000000..aa312f4c8a90
--- /dev/null
+++ b/pkgs/applications/misc/apvlv/default.nix
@@ -0,0 +1,48 @@
+{ stdenv, fetchurl, cmake, pkgconfig,
+  gtk2 , poppler, freetype, libpthreadstubs, libXdmcp, libxshmfence
+}:
+
+stdenv.mkDerivation rec {
+  version = "0.1.f7f7b9c";
+  name = "apvlv-${version}";
+
+  src = fetchurl {
+    url = "https://github.com/downloads/naihe2010/apvlv/${name}-Source.tar.gz";
+    sha256 = "125nlcfjdhgzi9jjxh9l2yc9g39l6jahf8qh2555q20xkxf4rl0w";
+  };
+
+  preConfigure = ''
+    export NIX_CFLAGS_COMPILE="$NIX_CFLAGS_COMPILE -I${poppler}/include/poppler"
+  '';
+
+  buildInputs = [
+    pkgconfig cmake
+     poppler
+     freetype gtk2
+     libpthreadstubs libXdmcp libxshmfence # otherwise warnings in compilation
+   ];
+
+  installPhase = ''
+    # binary
+    mkdir -p $out/bin
+    cp src/apvlv $out/bin/apvlv
+
+    # displays pdfStartup.pdf as default pdf entry
+    mkdir -p $out/share/doc/apvlv/
+    cp ../Startup.pdf $out/share/doc/apvlv/Startup.pdf
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = "http://naihe2010.github.io/apvlv/";
+    description = "PDF viewer with Vim-like behaviour";
+    longDescription = ''
+      apvlv is a PDF/DJVU/UMD/TXT Viewer Under Linux/WIN32
+      with Vim-like behaviour.
+    '';
+
+    license = licenses.lgpl2;
+    platforms = platforms.unix;
+    maintainers = [ maintainers.ardumont ];
+  };
+
+}