summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorcodyopel <codyopel@gmail.com>2015-06-01 06:56:42 -0400
committercodyopel <codyopel@gmail.com>2015-06-01 06:56:42 -0400
commitd866d4616dc41dac93f3c6c90383c205dae7e10a (patch)
tree5b90a79001d1edf5ce119790d7a1d0bb6bf08ae8 /pkgs/applications
parent13cc88f273f0cb6d13e39ecf61775c29dde6d21c (diff)
downloadnixlib-d866d4616dc41dac93f3c6c90383c205dae7e10a.tar
nixlib-d866d4616dc41dac93f3c6c90383c205dae7e10a.tar.gz
nixlib-d866d4616dc41dac93f3c6c90383c205dae7e10a.tar.bz2
nixlib-d866d4616dc41dac93f3c6c90383c205dae7e10a.tar.lz
nixlib-d866d4616dc41dac93f3c6c90383c205dae7e10a.tar.xz
nixlib-d866d4616dc41dac93f3c6c90383c205dae7e10a.tar.zst
nixlib-d866d4616dc41dac93f3c6c90383c205dae7e10a.zip
musescore: 2.0.0 -> 2.0.1
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/musescore/default.nix40
1 files changed, 30 insertions, 10 deletions
diff --git a/pkgs/applications/audio/musescore/default.nix b/pkgs/applications/audio/musescore/default.nix
index 9dbebe31a38e..bfbfa5775312 100644
--- a/pkgs/applications/audio/musescore/default.nix
+++ b/pkgs/applications/audio/musescore/default.nix
@@ -1,27 +1,47 @@
-{ stdenv, fetchurl, makeWrapper, cmake, qt5, pkgconfig, alsaLib, portaudio, jack2
-, lame, libsndfile, libvorbis }:
+{ stdenv, fetchurl, cmake, pkgconfig
+, alsaLib, freetype, jack2, lame, libogg, libpulseaudio, libsndfile, libvorbis
+, portaudio, qt5 #, tesseract
+}:
 
 stdenv.mkDerivation rec {
   name = "musescore-${version}";
-  version = "2.0.0";
+  version = "2.0.1";
 
   src = fetchurl {
     url = "https://github.com/musescore/MuseScore/archive/v${version}.tar.gz";
-    sha256 = "1a4fz9pqwz59brfa7qn61364hyd07lsq3lflkzn1w2q21d7xd20w";
+    sha256 = "0n4xk35jggdq2dcizqjq1kdpclih4scpl93ymmxahvfa1vvwn5iw";
   };
 
-  buildInputs = [
-    makeWrapper cmake qt5.base pkgconfig alsaLib portaudio jack2 lame libsndfile libvorbis
+  makeFlags = [
+    "PREFIX=$(out)"
+  ];
+
+  cmakeFlags = [
+    "-DAEOLUS=OFF"
+    "-DZERBERUS=ON"
+    "-DOSC=ON=ON"
+    "-DOMR=OFF" # TODO: add OMR support, CLEF_G not declared error
+    "-DOCR=OFF" # Not necessary without OMR
+    "-DSOUNDFONT3=ON"
+    "-DHAS_AUDIOFILE=ON"
+    "-DBUILD_JACK=ON"
   ];
 
-  patchPhase = ''
-    sed s,"/usr/local",$out, -i Makefile
+  preBuild = ''
+    make lupdate
+    make lrelease
   '';
 
-  preBuild = "make lrelease";
+  nativeBuildInputs = [ cmake pkgconfig ];
+
+  buildInputs = [
+    alsaLib jack2 freetype lame libogg libpulseaudio libsndfile libvorbis
+    portaudio qt5.base qt5.declarative qt5.enginio qt5.script qt5.svg qt5.tools
+    qt5.webkit qt5.xmlpatterns #tesseract
+  ];
 
   meta = with stdenv.lib; {
-    description = "Qt-based score editor";
+    description = "Music notation and composition software";
     homepage = http://musescore.org/;
     license = licenses.gpl2;
     platforms = platforms.linux;