summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorNikolay Amiantov <ab@fmap.me>2018-03-13 16:08:09 +0300
committerNikolay Amiantov <ab@fmap.me>2018-03-13 16:13:18 +0300
commitd7470c1f1e401cd3265a511871dafef4f8cafad5 (patch)
tree5e07f7be5f72ffe40bde74086a7a926282cf7a2c /pkgs/applications
parenta682ba23d49cd13c92922af3d5dc44efd60ae9e7 (diff)
downloadnixlib-d7470c1f1e401cd3265a511871dafef4f8cafad5.tar
nixlib-d7470c1f1e401cd3265a511871dafef4f8cafad5.tar.gz
nixlib-d7470c1f1e401cd3265a511871dafef4f8cafad5.tar.bz2
nixlib-d7470c1f1e401cd3265a511871dafef4f8cafad5.tar.lz
nixlib-d7470c1f1e401cd3265a511871dafef4f8cafad5.tar.xz
nixlib-d7470c1f1e401cd3265a511871dafef4f8cafad5.tar.zst
nixlib-d7470c1f1e401cd3265a511871dafef4f8cafad5.zip
android-studio: fix GTK LaF
Closes #36887.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/android-studio/common.nix6
-rw-r--r--pkgs/applications/editors/android-studio/default.nix3
2 files changed, 8 insertions, 1 deletions
diff --git a/pkgs/applications/editors/android-studio/common.nix b/pkgs/applications/editors/android-studio/common.nix
index 2c2227dd4ee9..5e6d44807eea 100644
--- a/pkgs/applications/editors/android-studio/common.nix
+++ b/pkgs/applications/editors/android-studio/common.nix
@@ -29,6 +29,7 @@
 , writeTextFile
 , xkeyboard_config
 , zlib
+, gtk2, gnome_vfs, glib, GConf
 , fontsConf
 }:
 
@@ -95,6 +96,11 @@ let
           libpulseaudio
           libX11
 
+          # For GTKLookAndFeel
+          gtk2
+          gnome_vfs
+          glib
+          GConf
         ]}" \
         --set QT_XKB_CONFIG_ROOT "${xkeyboard_config}/share/X11/xkb" \
         --set FONTCONFIG_FILE ${fontsConf}
diff --git a/pkgs/applications/editors/android-studio/default.nix b/pkgs/applications/editors/android-studio/default.nix
index e3c9fb5b14af..382066d1dbd1 100644
--- a/pkgs/applications/editors/android-studio/default.nix
+++ b/pkgs/applications/editors/android-studio/default.nix
@@ -1,9 +1,10 @@
-{ stdenv, callPackage, fetchurl, makeFontsConf }:
+{ stdenv, callPackage, fetchurl, makeFontsConf, gnome2 }:
 let
   mkStudio = opts: callPackage (import ./common.nix opts) {
     fontsConf = makeFontsConf {
       fontDirectories = [];
     };
+    inherit (gnome2) GConf gnome_vfs;
   };
 in rec {
   # Old alias