summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMatthew Justin Bauer <mjbauer95@gmail.com>2018-04-25 00:30:32 -0500
committerGitHub <noreply@github.com>2018-04-25 00:30:32 -0500
commitd71d7c913ec3bb35135d1ddfbe74e561ba08e5c0 (patch)
treebb6d982959d709f3d23a11d7fe48c56c9c28c4fa /pkgs/applications
parente4e85628066b0fa33ff5d3ba01ad24a50974639a (diff)
parent0a8c91a931ea270e8b1d66f592f6acba9b4b5fcf (diff)
downloadnixlib-d71d7c913ec3bb35135d1ddfbe74e561ba08e5c0.tar
nixlib-d71d7c913ec3bb35135d1ddfbe74e561ba08e5c0.tar.gz
nixlib-d71d7c913ec3bb35135d1ddfbe74e561ba08e5c0.tar.bz2
nixlib-d71d7c913ec3bb35135d1ddfbe74e561ba08e5c0.tar.lz
nixlib-d71d7c913ec3bb35135d1ddfbe74e561ba08e5c0.tar.xz
nixlib-d71d7c913ec3bb35135d1ddfbe74e561ba08e5c0.tar.zst
nixlib-d71d7c913ec3bb35135d1ddfbe74e561ba08e5c0.zip
Merge pull request #39465 from matthewbauer/work
Various work on broken packages
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/graphics/inkscape/default.nix28
1 files changed, 15 insertions, 13 deletions
diff --git a/pkgs/applications/graphics/inkscape/default.nix b/pkgs/applications/graphics/inkscape/default.nix
index 47452eb43e88..9a8ef6bd7744 100644
--- a/pkgs/applications/graphics/inkscape/default.nix
+++ b/pkgs/applications/graphics/inkscape/default.nix
@@ -2,9 +2,15 @@
 , libpng, zlib, popt, boehmgc, libxml2, libxslt, glib, gtkmm2
 , glibmm, libsigcxx, lcms, boost, gettext, makeWrapper
 , gsl, python2, poppler, imagemagick, libwpg, librevenge
-, libvisio, libcdr, libexif, potrace, cmake
+, libvisio, libcdr, libexif, potrace, autoreconfHook
+, intltool
+, lib
 }:
 
+# Note that originally this Nix expression used CMake to build but
+# this led to errors on MacOS of "Too many arguments". Inkscape
+# supports autoconf and we will use this for now on.
+
 let
   python2Env = python2.withPackages(ps: with ps; [ numpy lxml ]);
 in
@@ -17,12 +23,6 @@ stdenv.mkDerivation rec {
     sha256 = "1chng2yw8dsjxc9gf92aqv7plj11cav8ax321wmakmv5bb09cch6";
   };
 
-  unpackPhase = ''
-    cp $src ${name}.tar.bz2
-    tar xvjf ${name}.tar.bz2 > /dev/null
-    cd ${name}
-  '';
-
   postPatch = ''
     patchShebangs share/extensions
     patchShebangs fix-roff-punct
@@ -33,25 +33,26 @@ stdenv.mkDerivation rec {
       --replace '"python-interpreter", "python"' '"python-interpreter", "${python2Env}/bin/python"'
   '';
 
-  nativeBuildInputs = [ pkgconfig ];
+  nativeBuildInputs = [ pkgconfig autoreconfHook intltool ];
   buildInputs = [
     perl perlXMLParser libXft libpng zlib popt boehmgc
     libxml2 libxslt glib gtkmm2 glibmm libsigcxx lcms boost gettext
     makeWrapper gsl poppler imagemagick libwpg librevenge
-    libvisio libcdr libexif potrace cmake python2Env
+    libvisio libcdr libexif potrace python2Env
   ];
 
   enableParallelBuilding = true;
 
+  preConfigure = ''
+    intltoolize -f
+  '';
+
   postInstall = ''
     # Make sure PyXML modules can be found at run-time.
     rm "$out/share/icons/hicolor/icon-theme.cache"
-  '' + stdenv.lib.optionalString stdenv.isDarwin ''
-    install_name_tool -change $out/lib/libinkscape_base.dylib $out/lib/inkscape/libinkscape_base.dylib $out/bin/inkscape
-    install_name_tool -change $out/lib/libinkscape_base.dylib $out/lib/inkscape/libinkscape_base.dylib $out/bin/inkview
   '';
 
-  meta = with stdenv.lib; {
+  meta = with lib; {
     license = "GPL";
     homepage = https://www.inkscape.org;
     description = "Vector graphics editor";
@@ -62,5 +63,6 @@ stdenv.mkDerivation rec {
 
       If you want to import .eps files install ps2edit.
     '';
+    maintainers = with maintainers; [ matthewbauer ];
   };
 }