summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMatthew Justin Bauer <mjbauer95@gmail.com>2018-06-06 21:27:09 -0400
committerGitHub <noreply@github.com>2018-06-06 21:27:09 -0400
commitd6a97a524a46d657c82cb4c0ad567ece9faac651 (patch)
tree4d0a0fcfbf8c9ed43adc30992ee824866ab38291 /pkgs/applications
parentdc82e3efc550b68c6ab91080c1993b5574fc00c9 (diff)
parent220d2637c1747d4a91cc1e01aab25cc8941928cb (diff)
downloadnixlib-d6a97a524a46d657c82cb4c0ad567ece9faac651.tar
nixlib-d6a97a524a46d657c82cb4c0ad567ece9faac651.tar.gz
nixlib-d6a97a524a46d657c82cb4c0ad567ece9faac651.tar.bz2
nixlib-d6a97a524a46d657c82cb4c0ad567ece9faac651.tar.lz
nixlib-d6a97a524a46d657c82cb4c0ad567ece9faac651.tar.xz
nixlib-d6a97a524a46d657c82cb4c0ad567ece9faac651.tar.zst
nixlib-d6a97a524a46d657c82cb4c0ad567ece9faac651.zip
Merge pull request #41576 from MarcFontaine/xearth
xearth : init at 1.1
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/science/astronomy/xearth/default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/pkgs/applications/science/astronomy/xearth/default.nix b/pkgs/applications/science/astronomy/xearth/default.nix
new file mode 100644
index 000000000000..5f276a1b3c70
--- /dev/null
+++ b/pkgs/applications/science/astronomy/xearth/default.nix
@@ -0,0 +1,32 @@
+{ stdenv, fetchurl, xorg }:
+stdenv.mkDerivation rec {
+  name = "xearth-${version}";
+  version = "1.1";
+  
+  src = fetchurl {
+    url = "http://xearth.org/${name}.tar.gz";
+    sha256 = "bcb1407cc35b3f6dd3606b2c6072273b6a912cbd9ed1ae22fb2d26694541309c";
+  };
+
+  buildInputs = with xorg; [  imake libXt libXext ];
+
+  dontAddPrefix = true;
+  configureScript="xmkmf";
+
+  installFlags=[ "DESTDIR=$(out)/" "BINDIR=bin" "MANDIR=man/man1"];
+  installTargets="install install.man";
+  
+  meta = with stdenv.lib; {
+    description = "sets the X root window to an image of the Earth";
+    homepage = "http://xplanet.org";
+    longDescription =
+      '' Xearth  sets  the X root window to an image of the Earth, as seen from your favorite vantage point in space,
+         correctly shaded for the current position of the Sun.
+	 By default, xearth updates the displayed image every  five  minutes.
+      '';
+    maintainers = [ maintainers.mafo ];
+    license = "xearth";
+    platforms=platforms.unix;
+  };
+
+}