summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMatthew Justin Bauer <mjbauer95@gmail.com>2018-04-24 10:03:01 -0500
committerGitHub <noreply@github.com>2018-04-24 10:03:01 -0500
commitd57e6466e00c3294d321e8a203a2262f5d65808a (patch)
treec1846d694b73f48d4291e5141681243d30d90025 /pkgs/applications
parent7ebb6212a2c395394aea4362f397a111e2679031 (diff)
parent75b0866d0c750e4ef2fe1ed7ee1af9fd32f52874 (diff)
downloadnixlib-d57e6466e00c3294d321e8a203a2262f5d65808a.tar
nixlib-d57e6466e00c3294d321e8a203a2262f5d65808a.tar.gz
nixlib-d57e6466e00c3294d321e8a203a2262f5d65808a.tar.bz2
nixlib-d57e6466e00c3294d321e8a203a2262f5d65808a.tar.lz
nixlib-d57e6466e00c3294d321e8a203a2262f5d65808a.tar.xz
nixlib-d57e6466e00c3294d321e8a203a2262f5d65808a.tar.zst
nixlib-d57e6466e00c3294d321e8a203a2262f5d65808a.zip
Merge pull request #39377 from timokau/pari-pthread
pari: Make pthread optional, remove unstable
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/science/math/pari/default.nix20
-rw-r--r--pkgs/applications/science/math/pari/unstable.nix31
2 files changed, 16 insertions, 35 deletions
diff --git a/pkgs/applications/science/math/pari/default.nix b/pkgs/applications/science/math/pari/default.nix
index a1ddbd9ab17d..8c24881f2152 100644
--- a/pkgs/applications/science/math/pari/default.nix
+++ b/pkgs/applications/science/math/pari/default.nix
@@ -1,5 +1,9 @@
 { stdenv, fetchurl
-, gmp, readline, libX11, libpthreadstubs, tex, perl }:
+, gmp, readline, libX11, tex, perl
+, withThread ? true, libpthreadstubs
+}:
+
+assert withThread -> libpthreadstubs != null;
 
 stdenv.mkDerivation rec {
 
@@ -11,14 +15,22 @@ stdenv.mkDerivation rec {
     sha256 = "0ir6m3a8r46md5x6zk4xf159qra7aqparby9zk03k81hjrrxr72g";
   };
 
-  buildInputs = [ gmp readline libX11 libpthreadstubs tex perl ];
+  buildInputs = [
+    gmp
+    readline
+    libX11
+    tex
+    perl
+  ] ++ stdenv.lib.optionals withThread [
+    libpthreadstubs
+  ];
 
   configureScript = "./Configure";
   configureFlags = [
-    "--mt=pthread"
     "--with-gmp=${gmp.dev}"
     "--with-readline=${readline.dev}"
-  ] ++ stdenv.lib.optional stdenv.isDarwin "--host=x86_64-darwin";
+  ] ++ stdenv.lib.optional stdenv.isDarwin "--host=x86_64-darwin"
+  ++ stdenv.lib.optional withThread "--mt=pthread";
 
   preConfigure = ''
     export LD=$CC
diff --git a/pkgs/applications/science/math/pari/unstable.nix b/pkgs/applications/science/math/pari/unstable.nix
deleted file mode 100644
index 65dd3005b4ab..000000000000
--- a/pkgs/applications/science/math/pari/unstable.nix
+++ /dev/null
@@ -1,31 +0,0 @@
-{ stdenv, fetchurl, gmp, readline, perl }:
-
-stdenv.mkDerivation rec {
-  version = "2.9.3";
-  name = "pari-unstable-${version}";
-
-  src = fetchurl {
-    url = "http://pari.math.u-bordeaux.fr/pub/pari/unstable/pari-${version}.tar.gz";
-    sha256 = "0qqal1lpggd6dvs19svnz0dil86xk0xkcj5s3b7104ibkmvjfsp7";
-  };
-
-  buildInputs = [gmp readline];
-  nativeBuildInputs = [perl];
-
-  configureScript = "./Configure";
-  configureFlags =
-    "--with-gmp=${gmp.dev} " +
-    "--with-readline=${readline.dev}";
-
-  meta = with stdenv.lib; {
-    description = "Computer algebra system for high-performance number theory computations";
-    homepage    = "http://pari.math.u-bordeaux.fr/";
-    license     = licenses.gpl2Plus;
-    maintainers = with maintainers; [ ertes raskin ];
-    platforms   = platforms.linux;
-
-    inherit version;
-    downloadPage = "http://pari.math.u-bordeaux.fr/download.html";
-    updateWalker = true;
-  };
-}