summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorArseniy Seroka <jagajaga@users.noreply.github.com>2015-07-26 20:08:53 +0300
committerArseniy Seroka <jagajaga@users.noreply.github.com>2015-07-26 20:08:53 +0300
commitd3fa021448b4061f11ec41f0167573d17a02d2e7 (patch)
tree11a3b4b2353ad48ac5fa5b2ee62d1c41a0444e53 /pkgs/applications
parent99ac72994c83677fd04edc1f0faf8b0d47f539e7 (diff)
parenta0ab047fdbf1fe3c2d2c745e569d6b29bb305d56 (diff)
downloadnixlib-d3fa021448b4061f11ec41f0167573d17a02d2e7.tar
nixlib-d3fa021448b4061f11ec41f0167573d17a02d2e7.tar.gz
nixlib-d3fa021448b4061f11ec41f0167573d17a02d2e7.tar.bz2
nixlib-d3fa021448b4061f11ec41f0167573d17a02d2e7.tar.lz
nixlib-d3fa021448b4061f11ec41f0167573d17a02d2e7.tar.xz
nixlib-d3fa021448b4061f11ec41f0167573d17a02d2e7.tar.zst
nixlib-d3fa021448b4061f11ec41f0167573d17a02d2e7.zip
Merge pull request #8977 from AndersonTorres/cherrytree
Cherrytree: 0.35.8 -> 0.35.9
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/cherrytree/default.nix37
1 files changed, 27 insertions, 10 deletions
diff --git a/pkgs/applications/misc/cherrytree/default.nix b/pkgs/applications/misc/cherrytree/default.nix
index eb73f48559a6..97b67a3ae332 100644
--- a/pkgs/applications/misc/cherrytree/default.nix
+++ b/pkgs/applications/misc/cherrytree/default.nix
@@ -1,18 +1,24 @@
 { stdenv, fetchurl, python, pythonPackages, gettext, pygtksourceview, sqlite }:
 
+with stdenv.lib;
 stdenv.mkDerivation rec {
-  name = "cherrytree-0.35.8";
+
+  name = "cherrytree-${version}";
+  version = "0.35.9";
 
   src = fetchurl {
     url = "http://www.giuspen.com/software/${name}.tar.xz";
-    sha256 = "0vqc1idzd73f4q5f4zwwypj4jiivwnb4y0r3041h2pm08y1wgsd8";
+    sha256 = "14yahp0y13z3xkpwvprm7q9x3rj6jbzi0bryqlsn3bbafdq7wnac";
   };
 
-  propagatedBuildInputs = [ pythonPackages.sqlite3 ];
+  propagatedBuildInputs = with pythonPackages;
+  [ sqlite3 ];
 
-  buildInputs = with pythonPackages; [ python gettext wrapPython pygtk dbus pygtksourceview ];
+  buildInputs = with pythonPackages;
+  [ python gettext wrapPython pygtk dbus pygtksourceview ];
 
-  pythonPath = with pythonPackages; [ pygtk dbus pygtksourceview ];
+  pythonPath = with pythonPackages;
+  [ pygtk dbus pygtksourceview ];
 
   patches = [ ./subprocess.patch ];
 
@@ -27,10 +33,21 @@ stdenv.mkDerivation rec {
 
   doCheck = false;
 
-  meta = {
-    description = "A hierarchical note taking application, featuring rich text and syntax highlighting, storing data in a single xml or sqlite file";
+  meta = { 
+    description = "An hierarchical note taking application";
+    longDescription = ''
+      Cherrytree is an hierarchical note taking application,
+      featuring rich text, syntax highlighting and powerful search
+      capabilities. It organizes all information in units called
+      "nodes", as in a tree, and can be very useful to store any piece
+      of information, from tables and links to pictures and even entire
+      documents. All those little bits of information you have scattered
+      around your hard drive can be conveniently placed into a
+      Cherrytree document where you can easily find it.
+    ''; 
     homepage = http://www.giuspen.com/cherrytree;
-    license = stdenv.lib.licenses.gpl3;
-    platforms = with stdenv.lib.platforms; linux;
-  };
+    license = licenses.gpl3;
+    platforms = platforms.linux; 
+    maintainers = [ maintainers.AndersonTorres ]; 
+  }; 
 }