summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorFrederik Rietdijk <freddyrietdijk@fridh.nl>2018-07-13 18:52:26 +0200
committerGitHub <noreply@github.com>2018-07-13 18:52:26 +0200
commitd0446a5c76bed980ffaf36d8261520b44d6c7138 (patch)
tree05fe96f887ecc598d1626584385378907cb26b77 /pkgs/applications
parentae46f726388cfa50df1ce66a3b1411dbdd306859 (diff)
parent35896e350603ae03240ca4f8bf8fd7e1fb85a730 (diff)
downloadnixlib-d0446a5c76bed980ffaf36d8261520b44d6c7138.tar
nixlib-d0446a5c76bed980ffaf36d8261520b44d6c7138.tar.gz
nixlib-d0446a5c76bed980ffaf36d8261520b44d6c7138.tar.bz2
nixlib-d0446a5c76bed980ffaf36d8261520b44d6c7138.tar.lz
nixlib-d0446a5c76bed980ffaf36d8261520b44d6c7138.tar.xz
nixlib-d0446a5c76bed980ffaf36d8261520b44d6c7138.tar.zst
nixlib-d0446a5c76bed980ffaf36d8261520b44d6c7138.zip
Merge pull request #43436 from timokau/sage-new-flask
sage: replace flask-babel version pin by patch
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/science/math/sage/default.nix10
-rw-r--r--pkgs/applications/science/math/sage/sagenb.nix8
2 files changed, 8 insertions, 10 deletions
diff --git a/pkgs/applications/science/math/sage/default.nix b/pkgs/applications/science/math/sage/default.nix
index 9ad112213ffd..afb230cf4287 100644
--- a/pkgs/applications/science/math/sage/default.nix
+++ b/pkgs/applications/science/math/sage/default.nix
@@ -14,16 +14,6 @@ let
 
       cvxopt = super.cvxopt.override { inherit glpk; };
 
-      # https://github.com/sagemath/sagenb/issues/437
-      flask-babel = super.flask-babel.overridePythonAttrs (attrs: rec {
-        version = "0.9";
-        src = attrs.src.override {
-          inherit version;
-          sha256 = "0k7vk4k54y55ma0nx2k5s0phfqbriwslhy5shh3b0d046q7ibzaa";
-        };
-        doCheck = false;
-      });
-
       # python packages that appear unmaintained and were not accepted into the nixpkgs
       # tree because of that. These packages are only dependencies of the more-or-less
       # deprecated sagenb. However sagenb is still a default dependency and the doctests
diff --git a/pkgs/applications/science/math/sage/sagenb.nix b/pkgs/applications/science/math/sage/sagenb.nix
index 5ab387ebc5e1..cc883cc24b42 100644
--- a/pkgs/applications/science/math/sage/sagenb.nix
+++ b/pkgs/applications/science/math/sage/sagenb.nix
@@ -36,6 +36,14 @@ buildPythonPackage rec {
   # tests depend on sage
   doCheck = false;
 
+  patches = [
+    # work with latest flask-babel
+    (fetchpatch {
+      url = "https://github.com/sagemath/sagenb/commit/ba065eca63dd34a383e4c7ba7561430a90fcd087.patch";
+      sha256 = "1lamzsrgymdd618imrasjp6ivhw2aynh83gkybsd7pm1rzjcq4x8";
+    })
+  ];
+
   meta = with stdenv.lib; {
     description = "Sage Notebook";
     license = licenses.gpl3Plus;