summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMatthew Justin Bauer <mjbauer95@gmail.com>2018-04-08 21:19:46 -0500
committerGitHub <noreply@github.com>2018-04-08 21:19:46 -0500
commitcf9e5dd1a5dc8363a5fdaba3078f8a97f1e06bbe (patch)
tree2c376da2195078b06846a12bec938bf8ceef940c /pkgs/applications
parent734397afa0a578a126c75d622800f8c73e809788 (diff)
parentf582b0d3d1d8e673a057cc77af4168beb591ede8 (diff)
downloadnixlib-cf9e5dd1a5dc8363a5fdaba3078f8a97f1e06bbe.tar
nixlib-cf9e5dd1a5dc8363a5fdaba3078f8a97f1e06bbe.tar.gz
nixlib-cf9e5dd1a5dc8363a5fdaba3078f8a97f1e06bbe.tar.bz2
nixlib-cf9e5dd1a5dc8363a5fdaba3078f8a97f1e06bbe.tar.lz
nixlib-cf9e5dd1a5dc8363a5fdaba3078f8a97f1e06bbe.tar.xz
nixlib-cf9e5dd1a5dc8363a5fdaba3078f8a97f1e06bbe.tar.zst
nixlib-cf9e5dd1a5dc8363a5fdaba3078f8a97f1e06bbe.zip
Merge pull request #38081 from Ekleog/todiff
todiff: init at 0.4.0
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/todiff/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/applications/misc/todiff/default.nix b/pkgs/applications/misc/todiff/default.nix
new file mode 100644
index 000000000000..049a9eff347c
--- /dev/null
+++ b/pkgs/applications/misc/todiff/default.nix
@@ -0,0 +1,23 @@
+{ stdenv, rustPlatform, fetchFromGitHub }:
+
+rustPlatform.buildRustPackage rec {
+  name = "todiff-${version}";
+  version = "0.4.0";
+
+  src = fetchFromGitHub {
+    owner = "Ekleog";
+    repo = "todiff";
+    rev = version;
+    sha256 = "0n3sifinwhny651q1v1a6y9ybim1b0nd5s1z26sigjdhdvxckn65";
+  };
+
+  cargoSha256 = "0mxdpn98fvmxrp656vwxvzl9vprz5mvqj7d1hvvs4gsjrsiyp0fy";
+
+  meta = with stdenv.lib; {
+    description = "Human-readable diff for todo.txt files";
+    homepage = "https://github.com/Ekleog/todiff";
+    maintainers = with maintainers; [ ekleog ];
+    license = licenses.mit;
+    platforms = platforms.all;
+  };
+}