summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2015-06-19 04:15:49 +0200
committeraszlig <aszlig@redmoonstudios.org>2015-06-23 03:35:30 +0200
commitcadd675e7ae4dc1572b0536b8f036b0901dfacde (patch)
tree177f21000221cfc5d6131f749aae94a5fa5fb023 /pkgs/applications
parentc290595e5b60822d342c5e6354da4dac35a87c5a (diff)
downloadnixlib-cadd675e7ae4dc1572b0536b8f036b0901dfacde.tar
nixlib-cadd675e7ae4dc1572b0536b8f036b0901dfacde.tar.gz
nixlib-cadd675e7ae4dc1572b0536b8f036b0901dfacde.tar.bz2
nixlib-cadd675e7ae4dc1572b0536b8f036b0901dfacde.tar.lz
nixlib-cadd675e7ae4dc1572b0536b8f036b0901dfacde.tar.xz
nixlib-cadd675e7ae4dc1572b0536b8f036b0901dfacde.tar.zst
nixlib-cadd675e7ae4dc1572b0536b8f036b0901dfacde.zip
chromium: Disable "hotwording" by default.
There has been some recent news about that component extension on hacker
news:

https://news.ycombinator.com/item?id=9724409

Even though on our side it won't work, because we don't have NaCl
enabled by default or even working (I honestly haven't tested if it even
builds if enabled), we might get to the point where we can build with
NaCl enabled.

But until and even after that day, we want to have explicit control on
whether this extension is enabled.

Please also have a look at these two issues explaining the details
(about component extensions and the hotwording extension in particular):

https://crbug.com/491435
https://crbug.com/500922

Fixes issue #8358.

Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/browsers/chromium/common.nix2
-rw-r--r--pkgs/applications/networking/browsers/chromium/default.nix7
2 files changed, 6 insertions, 3 deletions
diff --git a/pkgs/applications/networking/browsers/chromium/common.nix b/pkgs/applications/networking/browsers/chromium/common.nix
index d3a0c86daf4c..f54f21ef8c07 100644
--- a/pkgs/applications/networking/browsers/chromium/common.nix
+++ b/pkgs/applications/networking/browsers/chromium/common.nix
@@ -21,6 +21,7 @@
 # package customization
 , enableSELinux ? false, libselinux ? null
 , enableNaCl ? false
+, enableHotwording ? false
 , useOpenSSL ? false, nss ? null, openssl ? null
 , gnomeSupport ? false, gnome ? null
 , gnomeKeyringSupport ? false, libgnome_keyring3 ? null
@@ -158,6 +159,7 @@ let
       use_pulseaudio = pulseSupport;
       linux_link_pulseaudio = pulseSupport;
       disable_nacl = !enableNaCl;
+      enable_hotwording = enableHotwording;
       use_openssl = useOpenSSL;
       selinux = enableSELinux;
       use_cups = cupsSupport;
diff --git a/pkgs/applications/networking/browsers/chromium/default.nix b/pkgs/applications/networking/browsers/chromium/default.nix
index 85b2e9b8051e..a69b44c637a5 100644
--- a/pkgs/applications/networking/browsers/chromium/default.nix
+++ b/pkgs/applications/networking/browsers/chromium/default.nix
@@ -4,6 +4,7 @@
 , channel ? "stable"
 , enableSELinux ? false
 , enableNaCl ? false
+, enableHotwording ? false
 , useOpenSSL ? false
 , gnomeSupport ? false
 , gnomeKeyringSupport ? false
@@ -26,9 +27,9 @@ let
     };
 
     mkChromiumDerivation = callPackage ./common.nix {
-      inherit enableSELinux enableNaCl useOpenSSL gnomeSupport
-              gnomeKeyringSupport proprietaryCodecs cupsSupport
-              pulseSupport hiDPISupport;
+      inherit enableSELinux enableNaCl enableHotwording useOpenSSL gnomeSupport
+              gnomeKeyringSupport proprietaryCodecs cupsSupport pulseSupport
+              hiDPISupport;
     };
 
     browser = callPackage ./browser.nix { };