summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorThomas Tuegel <ttuegel@gmail.com>2015-09-27 10:01:11 -0500
committerThomas Tuegel <ttuegel@gmail.com>2015-09-27 15:08:10 -0500
commitc9a6d288b5bd0785b3263adfdd94c7c4396192f7 (patch)
tree8b7652f1777093d8f2237fd71ac5db8a22d0344c /pkgs/applications
parent943c2bf0590fac691469cb915cf7f970bf8c55fd (diff)
downloadnixlib-c9a6d288b5bd0785b3263adfdd94c7c4396192f7.tar
nixlib-c9a6d288b5bd0785b3263adfdd94c7c4396192f7.tar.gz
nixlib-c9a6d288b5bd0785b3263adfdd94c7c4396192f7.tar.bz2
nixlib-c9a6d288b5bd0785b3263adfdd94c7c4396192f7.tar.lz
nixlib-c9a6d288b5bd0785b3263adfdd94c7c4396192f7.tar.xz
nixlib-c9a6d288b5bd0785b3263adfdd94c7c4396192f7.tar.zst
nixlib-c9a6d288b5bd0785b3263adfdd94c7c4396192f7.zip
vlc_qt5: build with Qt 5.5
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/video/vlc/default.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/pkgs/applications/video/vlc/default.nix b/pkgs/applications/video/vlc/default.nix
index 732d8cd8a0a4..e5db4c0b2db8 100644
--- a/pkgs/applications/video/vlc/default.nix
+++ b/pkgs/applications/video/vlc/default.nix
@@ -8,13 +8,14 @@
 , libass, libva, libdvbpsi, libdc1394, libraw1394, libopus
 , libvdpau, libsamplerate
 , onlyLibVLC ? false
-, qt4 ? null, qt5 ? null, withQt5 ? false
+, qt4 ? null
+, withQt5 ? false, qtbase ? null
 , jackSupport ? false
 }:
 
 with stdenv.lib;
 
-assert (withQt5 -> qt5 != null);
+assert (withQt5 -> qtbase != null);
 assert (!withQt5 -> qt4 != null);
 
 stdenv.mkDerivation rec {
@@ -35,7 +36,7 @@ stdenv.mkDerivation rec {
       xorg.xlibsWrapper xorg.libXv xorg.libXvMC xorg.libXpm xorg.xcbutilkeysyms
       libdc1394 libraw1394 libopus libebml libmatroska libvdpau libsamplerate
     ]
-    ++ (if withQt5 then with qt5; [ base ] else [qt4])
+    ++ [(if withQt5 then qtbase else qt4)]
     ++ optional jackSupport libjack2;
 
   nativeBuildInputs = [ pkgconfig ];