summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2018-04-30 21:18:59 +0100
committerGitHub <noreply@github.com>2018-04-30 21:18:59 +0100
commitc696ac922172f68e6eb994f74130caab89afda93 (patch)
tree6b2ae87a1ed9e458759985a377e28a5b4688415a /pkgs/applications
parent85333b20d66ef21a5ac8c45158222fdf097bc652 (diff)
parent1478878caba8c9c73780d3615cd1dea6a1686593 (diff)
downloadnixlib-c696ac922172f68e6eb994f74130caab89afda93.tar
nixlib-c696ac922172f68e6eb994f74130caab89afda93.tar.gz
nixlib-c696ac922172f68e6eb994f74130caab89afda93.tar.bz2
nixlib-c696ac922172f68e6eb994f74130caab89afda93.tar.lz
nixlib-c696ac922172f68e6eb994f74130caab89afda93.tar.xz
nixlib-c696ac922172f68e6eb994f74130caab89afda93.tar.zst
nixlib-c696ac922172f68e6eb994f74130caab89afda93.zip
Merge pull request #39379 from flokli/pdf-quench
pdf-quench: init at 1.0.5
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/pdf-quench/default.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/pkgs/applications/misc/pdf-quench/default.nix b/pkgs/applications/misc/pdf-quench/default.nix
new file mode 100644
index 000000000000..c567a7903b81
--- /dev/null
+++ b/pkgs/applications/misc/pdf-quench/default.nix
@@ -0,0 +1,36 @@
+{ stdenv, fetchFromGitHub, pkgs, pythonPackages, wrapGAppsHook}:
+
+pythonPackages.buildPythonApplication rec {
+  name = "pdf-quench-${version}";
+  version = "1.0.5";
+
+  src = fetchFromGitHub {
+    owner = "linuxerwang";
+    repo = "pdf-quench";
+    rev = "b72b3970b371026f9a7ebe6003581e8a63af98f6";
+    sha256 = "1rp9rlwr6rarcsxygv5x2c5psgwl6r69k0lsgribgyyla9cf2m7n";
+  };
+
+  nativeBuildInputs = [ wrapGAppsHook ];
+  buildInputs = with pkgs; [
+    gtk3
+    gobjectIntrospection
+    goocanvas2
+    poppler_gi
+  ];
+  propagatedBuildInputs = with pythonPackages; [ pygobject3 pypdf2 ];
+
+  format = "other";
+  doCheck = false;
+
+  installPhase = ''
+    install -D -T -m 755 src/pdf_quench.py $out/bin/pdf-quench
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = https://github.com/linuxerwang/pdf-quench;
+    description = "A visual tool for cropping pdf files";
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ flokli ];
+  };
+}