summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorFranz Pletz <fpletz@fnordicwalking.de>2018-03-12 23:49:34 +0000
committerGitHub <noreply@github.com>2018-03-12 23:49:34 +0000
commitc26f9600528672ce0cba037ac8c12f2c378ae3b2 (patch)
tree62c4ac0b3d1aebed141acef617299eb0e6cf3da0 /pkgs/applications
parent2c9d2d65266c2c3aca1e4c80215de8bee5295b04 (diff)
parent876420f04e4d29ed16c2e43774fab6e000526dfa (diff)
downloadnixlib-c26f9600528672ce0cba037ac8c12f2c378ae3b2.tar
nixlib-c26f9600528672ce0cba037ac8c12f2c378ae3b2.tar.gz
nixlib-c26f9600528672ce0cba037ac8c12f2c378ae3b2.tar.bz2
nixlib-c26f9600528672ce0cba037ac8c12f2c378ae3b2.tar.lz
nixlib-c26f9600528672ce0cba037ac8c12f2c378ae3b2.tar.xz
nixlib-c26f9600528672ce0cba037ac8c12f2c378ae3b2.tar.zst
nixlib-c26f9600528672ce0cba037ac8c12f2c378ae3b2.zip
Merge pull request #36835 from YorikSar/fix-bitcoin-unlimited
bitcoin-unlimited: fix build with boost 1.66
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/altcoins/bitcoin-unlimited-const-comparators.patch38
-rw-r--r--pkgs/applications/altcoins/bitcoin-unlimited.nix5
2 files changed, 43 insertions, 0 deletions
diff --git a/pkgs/applications/altcoins/bitcoin-unlimited-const-comparators.patch b/pkgs/applications/altcoins/bitcoin-unlimited-const-comparators.patch
new file mode 100644
index 000000000000..1b74a48a84aa
--- /dev/null
+++ b/pkgs/applications/altcoins/bitcoin-unlimited-const-comparators.patch
@@ -0,0 +1,38 @@
+--- a/src/txmempool.h
++++ b/src/txmempool.h
+@@ -204,7 +204,7 @@
+ class CompareTxMemPoolEntryByDescendantScore
+ {
+ public:
+-    bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b)
++    bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b) const
+     {
+         bool fUseADescendants = UseDescendantScore(a);
+         bool fUseBDescendants = UseDescendantScore(b);
+@@ -226,7 +226,7 @@
+     }
+ 
+     // Calculate which score to use for an entry (avoiding division).
+-    bool UseDescendantScore(const CTxMemPoolEntry &a)
++    bool UseDescendantScore(const CTxMemPoolEntry &a) const
+     {
+         double f1 = (double)a.GetModifiedFee() * a.GetSizeWithDescendants();
+         double f2 = (double)a.GetModFeesWithDescendants() * a.GetTxSize();
+@@ -241,7 +241,7 @@
+ class CompareTxMemPoolEntryByScore
+ {
+ public:
+-    bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b)
++    bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b) const
+     {
+         double f1 = (double)a.GetModifiedFee() * b.GetTxSize();
+         double f2 = (double)b.GetModifiedFee() * a.GetTxSize();
+@@ -255,7 +255,7 @@
+ class CompareTxMemPoolEntryByEntryTime
+ {
+ public:
+-    bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b)
++    bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b) const
+     {
+         return a.GetTime() < b.GetTime();
+     }
diff --git a/pkgs/applications/altcoins/bitcoin-unlimited.nix b/pkgs/applications/altcoins/bitcoin-unlimited.nix
index 9eb1e54b9093..23d9e63459ab 100644
--- a/pkgs/applications/altcoins/bitcoin-unlimited.nix
+++ b/pkgs/applications/altcoins/bitcoin-unlimited.nix
@@ -21,8 +21,13 @@ stdenv.mkDerivation rec {
                   miniupnpc utillinux protobuf libevent ]
                   ++ optionals withGui [ qt4 qrencode ];
 
+  patches = [
+    ./bitcoin-unlimited-const-comparators.patch
+  ];
+
   configureFlags = [ "--with-boost-libdir=${boost.out}/lib" ]
                      ++ optionals withGui [ "--with-gui=qt4" ];
+  enableParallelBuilding = true;
 
   meta = {
     description = "Peer-to-peer electronic cash system (Unlimited client)";