summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorThomas Tuegel <ttuegel@gmail.com>2015-09-27 14:44:15 -0500
committerThomas Tuegel <ttuegel@gmail.com>2015-09-27 15:09:51 -0500
commitc20b7ba4f35bdce4ef8c7566defeb6dbe272dde1 (patch)
tree1f727b567a244f7b355fd65879cc1e439b7e7312 /pkgs/applications
parent3ae6dabaedf558349379a081d7acb321988ca647 (diff)
downloadnixlib-c20b7ba4f35bdce4ef8c7566defeb6dbe272dde1.tar
nixlib-c20b7ba4f35bdce4ef8c7566defeb6dbe272dde1.tar.gz
nixlib-c20b7ba4f35bdce4ef8c7566defeb6dbe272dde1.tar.bz2
nixlib-c20b7ba4f35bdce4ef8c7566defeb6dbe272dde1.tar.lz
nixlib-c20b7ba4f35bdce4ef8c7566defeb6dbe272dde1.tar.xz
nixlib-c20b7ba4f35bdce4ef8c7566defeb6dbe272dde1.tar.zst
nixlib-c20b7ba4f35bdce4ef8c7566defeb6dbe272dde1.zip
cool-retro-term: build with Qt 5.5
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/cool-retro-term/default.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/pkgs/applications/misc/cool-retro-term/default.nix b/pkgs/applications/misc/cool-retro-term/default.nix
index 455d33860fb6..9f97e1eccee6 100644
--- a/pkgs/applications/misc/cool-retro-term/default.nix
+++ b/pkgs/applications/misc/cool-retro-term/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchgit, makeWrapper, qt5, qmltermwidget }:
+{ stdenv, fetchgit, makeWrapper, qtbase, qtquick1, qmltermwidget }:
 
 stdenv.mkDerivation rec {
   version = "1.0.0";
@@ -15,7 +15,7 @@ stdenv.mkDerivation rec {
     sed -i -e '/qmltermwidget/d' cool-retro-term.pro
   '';
 
-  buildInputs = [ makeWrapper qt5.base qt5.quick1 qmltermwidget ];
+  buildInputs = [ makeWrapper qtbase qtquick1 qmltermwidget ];
 
   configurePhase = "qmake PREFIX=$out";
 
@@ -26,8 +26,7 @@ stdenv.mkDerivation rec {
     mv $out/usr/bin $out/bin
     rmdir $out/usr
 
-    wrapProgram $out/bin/cool-retro-term \
-      --prefix QML2_IMPORT_PATH : "${qmltermwidget}/lib/qml/"
+    wrapQtProgram $out/bin/cool-retro-term
   '';
 
   enableParallelBuilding = true;