summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMatthew Justin Bauer <mjbauer95@gmail.com>2018-05-02 12:49:02 -0500
committerGitHub <noreply@github.com>2018-05-02 12:49:02 -0500
commitbead42df5d400aba2e8686988dc39ca0f1f9e131 (patch)
tree695cd1ef02ee510e3f2d6b8e5f2aeba37fee435b /pkgs/applications
parent89e995d215172f3d1dccbb7eb13c2a5703ad1840 (diff)
parent51a8848f122108f997ac6923f3ec497f5d6391d7 (diff)
downloadnixlib-bead42df5d400aba2e8686988dc39ca0f1f9e131.tar
nixlib-bead42df5d400aba2e8686988dc39ca0f1f9e131.tar.gz
nixlib-bead42df5d400aba2e8686988dc39ca0f1f9e131.tar.bz2
nixlib-bead42df5d400aba2e8686988dc39ca0f1f9e131.tar.lz
nixlib-bead42df5d400aba2e8686988dc39ca0f1f9e131.tar.xz
nixlib-bead42df5d400aba2e8686988dc39ca0f1f9e131.tar.zst
nixlib-bead42df5d400aba2e8686988dc39ca0f1f9e131.zip
Merge pull request #37639 from Twey/plover-4.0.0.dev6
Plover 4.0.0.dev6
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/plover/default.nix59
1 files changed, 40 insertions, 19 deletions
diff --git a/pkgs/applications/misc/plover/default.nix b/pkgs/applications/misc/plover/default.nix
index b8fa38268c38..09558ff4c47f 100644
--- a/pkgs/applications/misc/plover/default.nix
+++ b/pkgs/applications/misc/plover/default.nix
@@ -1,26 +1,47 @@
-{ stdenv, fetchurl, python27Packages, wmctrl }:
+{ stdenv, fetchurl, python27Packages, python36Packages, wmctrl }:
 
-python27Packages.buildPythonPackage rec {
-  name = "plover-${version}";
-  version = "3.1.0";
+{
+  stable = with python27Packages; buildPythonPackage rec {
+    name    = "plover-${version}";
+    version = "3.1.1";
 
-  meta = with stdenv.lib; {
-    description = "OpenSteno Plover stenography software";
-    maintainers = with maintainers; [ twey kovirobi ];
-    license = licenses.gpl2;
-  };
+    meta = with stdenv.lib; {
+      description = "OpenSteno Plover stenography software";
+      maintainers = with maintainers; [ twey kovirobi ];
+      license     = licenses.gpl2;
+    };
+
+    src = fetchurl {
+      url    = "https://github.com/openstenoproject/plover/archive/v${version}.tar.gz";
+      sha256 = "1hdg5491phx6svrxxsxp8v6n4b25y7y4wxw7x3bxlbyhaskgj53r";
+    };
 
-  src = fetchurl {
-    url = "https://github.com/openstenoproject/plover/archive/v${version}.tar.gz";
-    sha256 = "1zdlgyjp93sfvk6by7rsh9hj4ijzplglrxpcpkcir6c3nq2bixl4";
+    buildInputs           = [ pytest mock ];
+    propagatedBuildInputs = [
+      six setuptools pyserial appdirs hidapi wxPython xlib wmctrl
+    ];
   };
 
-  # This is a fix for https://github.com/pypa/pip/issues/3624 causing regression https://github.com/pypa/pip/issues/3781
-  postPatch = ''
-    substituteInPlace setup.py --replace " in sys_platform" " == sys_platform"
-    '';
+  dev = with python36Packages; buildPythonPackage rec {
+    name    = "plover-${version}";
+    version = "4.0.0.dev6";
+
+    meta = with stdenv.lib; {
+      description = "OpenSteno Plover stenography software";
+      maintainers = with maintainers; [ twey kovirobi ];
+      license     = licenses.gpl2;
+    };
 
-  buildInputs = with python27Packages; [ pytest mock ];
-  propagatedBuildInputs = with python27Packages; [ six setuptools pyserial appdirs hidapi
-    wxPython xlib wmctrl ];
+    src = fetchurl {
+      url    = "https://github.com/openstenoproject/plover/archive/v${version}.tar.gz";
+      sha256 = "067rkpqnjjxwyv9cwh9i925ndba6fvj6q0r56lizy0l26b4jc8rp";
+    };
+
+    # I'm not sure why we don't find PyQt5 here but there's a similar
+    # sed on many of the platforms Plover builds for
+    postPatch = "sed -i /PyQt5/d setup.cfg";
+
+    buildInputs           = [ pytest mock ];
+    propagatedBuildInputs = [ Babel pyqt5 xlib pyserial appdirs ];
+  };
 }