summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorBart Brouns <bart@magnetophon.nl>2015-03-25 13:37:19 +0100
committerBart Brouns <bart@magnetophon.nl>2015-03-25 13:37:19 +0100
commitbd3e18d60fdb1c828bd6482a93a4dc5a04e030c8 (patch)
tree9ad842af58b33e181f77283f776ba0e69222773f /pkgs/applications
parent164dbfff80e7d314a68b845ca4183dd485a26685 (diff)
downloadnixlib-bd3e18d60fdb1c828bd6482a93a4dc5a04e030c8.tar
nixlib-bd3e18d60fdb1c828bd6482a93a4dc5a04e030c8.tar.gz
nixlib-bd3e18d60fdb1c828bd6482a93a4dc5a04e030c8.tar.bz2
nixlib-bd3e18d60fdb1c828bd6482a93a4dc5a04e030c8.tar.lz
nixlib-bd3e18d60fdb1c828bd6482a93a4dc5a04e030c8.tar.xz
nixlib-bd3e18d60fdb1c828bd6482a93a4dc5a04e030c8.tar.zst
nixlib-bd3e18d60fdb1c828bd6482a93a4dc5a04e030c8.zip
rebase mutt-kz on master, as requested in:
https://github.com/NixOS/nixpkgs/pull/6836
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/mailreaders/mutt-kz/default.nix64
1 files changed, 64 insertions, 0 deletions
diff --git a/pkgs/applications/networking/mailreaders/mutt-kz/default.nix b/pkgs/applications/networking/mailreaders/mutt-kz/default.nix
new file mode 100644
index 000000000000..a162df9f33b2
--- /dev/null
+++ b/pkgs/applications/networking/mailreaders/mutt-kz/default.nix
@@ -0,0 +1,64 @@
+{ stdenv, fetchurl, ncurses, which, perl, autoreconfHook, autoconf, automake, notmuch
+, sslSupport ? true
+, imapSupport ? true
+, headerCache ? true
+, saslSupport ? true
+, gpgmeSupport ? true
+, gdbm ? null
+, openssl ? null
+, cyrus_sasl ? null
+, gpgme ? null
+}:
+
+assert headerCache -> gdbm != null;
+assert sslSupport -> openssl != null;
+assert saslSupport -> cyrus_sasl != null;
+assert gpgmeSupport -> gpgme != null;
+
+let
+  version = "1.5.23.1-rc1";
+in
+stdenv.mkDerivation rec {
+  name = "mutt-kz-${version}";
+
+  src = fetchurl {
+    url = "https://github.com/karelzak/mutt-kz/archive/v${version}.tar.gz";
+    sha256 = "1m4bnn8psyrx2wy8ribannmp5qf75lv1gz116plji2z37z015zny";
+  };
+
+  buildInputs = with stdenv.lib;
+    [ ncurses which perl autoreconfHook autoconf automake notmuch]
+    ++ optional headerCache gdbm
+    ++ optional sslSupport openssl
+    ++ optional saslSupport cyrus_sasl
+    ++ optional gpgmeSupport gpgme;
+
+configureFlags = [
+    "--with-mailpath=" "--enable-smtp"
+
+    # This allows calls with "-d N", that output debug info into ~/.muttdebug*
+    "--enable-debug"
+
+    "--enable-pop" "--enable-imap"
+
+    "--enable-notmuch"
+
+    # The next allows building mutt without having anything setgid
+    # set by the installer, and removing the need for the group 'mail'
+    # I set the value 'mailbox' because it is a default in the configure script
+    "--with-homespool=mailbox"
+    (if headerCache then "--enable-hcache" else "--disable-hcache")
+    (if sslSupport then "--with-ssl" else "--without-ssl")
+    (if imapSupport then "--enable-imap" else "--disable-imap")
+    (if saslSupport then "--with-sasl" else "--without-sasl")
+    (if gpgmeSupport then "--enable-gpgme" else "--disable-gpgme")
+  ];
+
+  meta = with stdenv.lib; {
+    description = "A small but very powerful text-based mail client, forked to support notmuch";
+    homepage = https://github.com/karelzak/mutt-kz/;
+    license = stdenv.lib.licenses.gpl2Plus;
+    platforms = platforms.unix;
+    maintainers = with maintainers; [ magnetophon ];
+  };
+}