summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMarc Weber <marco-oweber@gmx.de>2010-01-04 07:44:24 +0000
committerMarc Weber <marco-oweber@gmx.de>2010-01-04 07:44:24 +0000
commitbbf825398542c1998ff9c2ef0700e44c57c13c61 (patch)
treeceee23352ff5b18feb3f56720da510706754a823 /pkgs/applications
parent08b30119539182d2d4228e07954644787d5052f0 (diff)
downloadnixlib-bbf825398542c1998ff9c2ef0700e44c57c13c61.tar
nixlib-bbf825398542c1998ff9c2ef0700e44c57c13c61.tar.gz
nixlib-bbf825398542c1998ff9c2ef0700e44c57c13c61.tar.bz2
nixlib-bbf825398542c1998ff9c2ef0700e44c57c13c61.tar.lz
nixlib-bbf825398542c1998ff9c2ef0700e44c57c13c61.tar.xz
nixlib-bbf825398542c1998ff9c2ef0700e44c57c13c61.tar.zst
nixlib-bbf825398542c1998ff9c2ef0700e44c57c13c61.zip
adding debug version of i686 flash player. See comments
svn path=/nixpkgs/trunk/; revision=19195
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/browsers/mozilla-plugins/flashplayer-10/default.nix44
1 files changed, 36 insertions, 8 deletions
diff --git a/pkgs/applications/networking/browsers/mozilla-plugins/flashplayer-10/default.nix b/pkgs/applications/networking/browsers/mozilla-plugins/flashplayer-10/default.nix
index c91b011de3a7..c4e4c3940192 100644
--- a/pkgs/applications/networking/browsers/mozilla-plugins/flashplayer-10/default.nix
+++ b/pkgs/applications/networking/browsers/mozilla-plugins/flashplayer-10/default.nix
@@ -16,24 +16,47 @@
 , glib
 , pango
 , atk
+, debug ? false
+
+/* you have to add ~/mm.cfg :
+
+    TraceOutputFileEnable=1
+    ErrorReportingEnable=1
+    MaxWarnings=1
+
+  in order to read the flash trace at ~/.macromedia/Flash_Player/Logs/flashlog.txt
+  Then FlashBug (a FireFox plugin) shows the log as well
+*/
+
 }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation ({
   name = "flashplayer-10.0.32.18";
 
   builder = ./builder.sh;
   
   src =
     if stdenv.system == "x86_64-linux" then
-      fetchurl {
-        url = http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-10.0.32.18.linux-x86_64.so.tar.gz;
-        sha256 = "006k3jvahlq2v34q5mf2y7ghczhy6spsdd69fj120i9yz9zklhpw";
-      }
+      fetchurl (
+        if debug then
+          # no plans to provide a x86_64 version:
+          # http://labs.adobe.com/technologies/flashplayer10/faq.html
+          throw "no x86_64 debugging version available"
+        else {
+          # -> http://labs.adobe.com/downloads/flashplayer10_64bit.html
+          url = http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-10.0.32.18.linux-x86_64.so.tar.gz;
+          sha256 = "006k3jvahlq2v34q5mf2y7ghczhy6spsdd69fj120i9yz9zklhpw";
+        }
+      )
     else
-      fetchurl {
+      fetchurl ( if debug then {
+        # The debug version also contains a player
+        url = http://download.macromedia.com/pub/flashplayer/updaters/10/flash_player_10_linux_dev.tar.gz;
+        sha256 = "0j3i4sbry9xdln23892hbkfbznqg2wzrakpfv4g5g6y7r2nchkfj";
+      } else {
         url = http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz;
         sha256 = "04ppx812dz4d93pkyx412z3jslkw8nsqw5gni467ipahqz6lifhi";
-      };
+      });
 
   inherit zlib alsaLib;
 
@@ -47,4 +70,9 @@ stdenv.mkDerivation {
     description = "Adobe Flash Player browser plugin";
     homepage = http://www.adobe.com/products/flashplayer/;
   };
-}
+} // (if debug then {
+    buildPhase = ''
+      pwd;ls -l .
+      tar xfz plugin/debugger/libflashplayer.so.tar.gz
+    '';
+  } else {} ) )