summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2016-04-15 04:25:47 +0200
committeraszlig <aszlig@redmoonstudios.org>2016-04-15 05:26:02 +0200
commitbb543e1540e0e70180e60285b7a353f0c32dc101 (patch)
treef458c29eae225c4eb55bfebb78499d0755d50e77 /pkgs/applications
parent97d89ad7eee9dcfd17b696ebd69b30d242c2d3cb (diff)
downloadnixlib-bb543e1540e0e70180e60285b7a353f0c32dc101.tar
nixlib-bb543e1540e0e70180e60285b7a353f0c32dc101.tar.gz
nixlib-bb543e1540e0e70180e60285b7a353f0c32dc101.tar.bz2
nixlib-bb543e1540e0e70180e60285b7a353f0c32dc101.tar.lz
nixlib-bb543e1540e0e70180e60285b7a353f0c32dc101.tar.xz
nixlib-bb543e1540e0e70180e60285b7a353f0c32dc101.tar.zst
nixlib-bb543e1540e0e70180e60285b7a353f0c32dc101.zip
iannix: Fix running of {pre,post}Configure
Commit 0055c6a introduced a new preConfigure hook that sets the right
qmake path. Unfortunately the mkDerivation attributes of iannix override
the whole configurePhase, so this hook isn't run at all.

This fixes the build of iannix and it now successfully compiles on my
machine.

Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/iannix/default.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/pkgs/applications/audio/iannix/default.nix b/pkgs/applications/audio/iannix/default.nix
index b2dde5b5b31f..f17abf975218 100644
--- a/pkgs/applications/audio/iannix/default.nix
+++ b/pkgs/applications/audio/iannix/default.nix
@@ -13,7 +13,11 @@ stdenv.mkDerivation rec {
 
     buildInputs = [ alsaLib pkgconfig qt5.qtbase qt5.qtscript ];
 
-  configurePhase = ''qmake PREFIX=/'';
+  configurePhase = ''
+    runHook preConfigure
+    qmake PREFIX=/
+    runHook postConfigure
+  '';
 
   installFlags = [ "INSTALL_ROOT=$(out)" ];