summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorDaiderd Jordan <daiderd@gmail.com>2018-11-06 20:15:27 +0100
committerGitHub <noreply@github.com>2018-11-06 20:15:27 +0100
commitb6dcb9e641950d1ce2e56724573e77b9999ed043 (patch)
tree2cd39e9aa154c731fa67ac663e1895f0f4cf77b6 /pkgs/applications
parentaed2dea55a9399c9513e65ff8248aff0205b5a3e (diff)
parentecf7c9c4b4e7f5b3737cb4a92570333fde7684c0 (diff)
downloadnixlib-b6dcb9e641950d1ce2e56724573e77b9999ed043.tar
nixlib-b6dcb9e641950d1ce2e56724573e77b9999ed043.tar.gz
nixlib-b6dcb9e641950d1ce2e56724573e77b9999ed043.tar.bz2
nixlib-b6dcb9e641950d1ce2e56724573e77b9999ed043.tar.lz
nixlib-b6dcb9e641950d1ce2e56724573e77b9999ed043.tar.xz
nixlib-b6dcb9e641950d1ce2e56724573e77b9999ed043.tar.zst
nixlib-b6dcb9e641950d1ce2e56724573e77b9999ed043.zip
Merge pull request #49768 from LnL7/darwin-no-cfprivate
darwin: don't include cf-private in framework dependencies
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/emacs/default.nix11
-rw-r--r--pkgs/applications/editors/vim/default.nix8
2 files changed, 13 insertions, 6 deletions
diff --git a/pkgs/applications/editors/emacs/default.nix b/pkgs/applications/editors/emacs/default.nix
index c1bfdf8157da..e95d2b615359 100644
--- a/pkgs/applications/editors/emacs/default.nix
+++ b/pkgs/applications/editors/emacs/default.nix
@@ -1,7 +1,7 @@
 { stdenv, lib, fetchurl, ncurses, xlibsWrapper, libXaw, libXpm, Xaw3d
 , pkgconfig, gettext, libXft, dbus, libpng, libjpeg, libungif
 , libtiff, librsvg, gconf, libxml2, imagemagick, gnutls, libselinux
-, alsaLib, cairo, acl, gpm, AppKit, GSS, ImageIO, m17n_lib, libotf
+, alsaLib, cairo, acl, gpm, cf-private, AppKit, GSS, ImageIO, m17n_lib, libotf
 , systemd ? null
 , withX ? !stdenv.isDarwin
 , withNS ? stdenv.isDarwin
@@ -64,9 +64,12 @@ stdenv.mkDerivation rec {
     ++ lib.optional (withX && withGTK2) gtk2-x11
     ++ lib.optionals (withX && withGTK3) [ gtk3-x11 gsettings-desktop-schemas ]
     ++ lib.optional (stdenv.isDarwin && withX) cairo
-    ++ lib.optionals (withX && withXwidgets) [ webkitgtk ];
-
-  propagatedBuildInputs = lib.optionals withNS [ AppKit GSS ImageIO ];
+    ++ lib.optionals (withX && withXwidgets) [ webkitgtk ]
+    ++ lib.optionals withNS [
+      AppKit GSS ImageIO
+      # Needed for CFNotificationCenterAddObserver symbols.
+      cf-private
+    ];
 
   hardeningDisable = [ "format" ];
 
diff --git a/pkgs/applications/editors/vim/default.nix b/pkgs/applications/editors/vim/default.nix
index 26cd61d182bd..2f34a6ddeb6b 100644
--- a/pkgs/applications/editors/vim/default.nix
+++ b/pkgs/applications/editors/vim/default.nix
@@ -6,7 +6,7 @@
     sha256 = "18ifhv5q9prd175q3vxbqf6qyvkk6bc7d2lhqdk0q78i68kv9y0c";
   }
 # apple frameworks
-, Carbon, Cocoa
+, cf-private, Carbon, Cocoa
 }:
 
 let
@@ -19,7 +19,11 @@ stdenv.mkDerivation rec {
 
   nativeBuildInputs = [ gettext pkgconfig ];
   buildInputs = [ ncurses ]
-    ++ stdenv.lib.optionals stdenv.hostPlatform.isDarwin [ Carbon Cocoa ];
+    ++ stdenv.lib.optionals stdenv.hostPlatform.isDarwin [
+      Carbon Cocoa
+      # Needed for OBJC_CLASS_$_NSArray symbols.
+      cf-private
+    ];
 
   configureFlags = [
     "--enable-multibyte"