summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorPhilipp Middendorf <middendorf@plapadoo.de>2018-05-03 13:40:48 +0200
committerPhilipp Middendorf <middendorf@plapadoo.de>2018-05-03 15:07:06 +0200
commitb62788f744225e5ff498059e7c5b9048d31f966d (patch)
treedcb004740c9c3b0917f34a60efde3cec268c9ad7 /pkgs/applications
parentb30c6d795035ad93932994cc28e909f0f6131070 (diff)
downloadnixlib-b62788f744225e5ff498059e7c5b9048d31f966d.tar
nixlib-b62788f744225e5ff498059e7c5b9048d31f966d.tar.gz
nixlib-b62788f744225e5ff498059e7c5b9048d31f966d.tar.bz2
nixlib-b62788f744225e5ff498059e7c5b9048d31f966d.tar.lz
nixlib-b62788f744225e5ff498059e7c5b9048d31f966d.tar.xz
nixlib-b62788f744225e5ff498059e7c5b9048d31f966d.tar.zst
nixlib-b62788f744225e5ff498059e7c5b9048d31f966d.zip
ledger: enable python command
ledger in nixpkgs currently uses python (it’s in buildInputs), but the
ledger python command isn’t available until you turn it on via a cmake
flag.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/office/ledger/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/applications/office/ledger/default.nix b/pkgs/applications/office/ledger/default.nix
index bb6e529f5d29..9675293cfe57 100644
--- a/pkgs/applications/office/ledger/default.nix
+++ b/pkgs/applications/office/ledger/default.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchFromGitHub, cmake, boost, gmp, mpfr, libedit, python
-, texinfo, gnused }:
+, texinfo, gnused, usePython ? true }:
 
 stdenv.mkDerivation rec {
   name = "ledger-${version}";
@@ -19,7 +19,7 @@ stdenv.mkDerivation rec {
 
   enableParallelBuilding = true;
 
-  cmakeFlags = [ "-DCMAKE_INSTALL_LIBDIR=lib" ];
+  cmakeFlags = [ "-DCMAKE_INSTALL_LIBDIR=lib" (stdenv.lib.optionalString usePython "-DUSE_PYTHON=true") ];
 
   # Skip byte-compiling of emacs-lisp files because this is currently
   # broken in ledger...