summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-08-29 17:48:49 -0700
committerWilliam A. Kennington III <william@wkennington.com>2015-08-29 17:48:49 -0700
commitafe1f0f12706f68d3b8363a0c765d4fecad5c690 (patch)
tree28827fc4536ec3a4aad795ba905e6833e0c89f63 /pkgs/applications
parent86e53bdff394951165fddc8aac5a1cfde79fc4c2 (diff)
parente9a8c5a988901a7e9c6f26214916ade70f262a45 (diff)
downloadnixlib-afe1f0f12706f68d3b8363a0c765d4fecad5c690.tar
nixlib-afe1f0f12706f68d3b8363a0c765d4fecad5c690.tar.gz
nixlib-afe1f0f12706f68d3b8363a0c765d4fecad5c690.tar.bz2
nixlib-afe1f0f12706f68d3b8363a0c765d4fecad5c690.tar.lz
nixlib-afe1f0f12706f68d3b8363a0c765d4fecad5c690.tar.xz
nixlib-afe1f0f12706f68d3b8363a0c765d4fecad5c690.tar.zst
nixlib-afe1f0f12706f68d3b8363a0c765d4fecad5c690.zip
Merge branch 'master.upstream' into staging.upstream
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/altcoins/bitcoin-xt.nix39
-rw-r--r--pkgs/applications/altcoins/default.nix3
-rw-r--r--pkgs/applications/audio/petrifoo/default.nix4
-rw-r--r--pkgs/applications/misc/calibre/default.nix4
-rw-r--r--pkgs/applications/misc/qtpass/default.nix4
-rw-r--r--pkgs/applications/misc/xca/0001-Fix-for-openssl-1.0.1i.patch57
-rw-r--r--pkgs/applications/misc/xca/default.nix12
-rw-r--r--pkgs/applications/science/programming/kframework/default.nix102
-rw-r--r--pkgs/applications/science/spyder/default.nix14
-rw-r--r--pkgs/applications/version-management/cvs-fast-export/default.nix1
-rw-r--r--pkgs/applications/virtualization/docker/default.nix4
11 files changed, 63 insertions, 181 deletions
diff --git a/pkgs/applications/altcoins/bitcoin-xt.nix b/pkgs/applications/altcoins/bitcoin-xt.nix
new file mode 100644
index 000000000000..e6c95729c6ec
--- /dev/null
+++ b/pkgs/applications/altcoins/bitcoin-xt.nix
@@ -0,0 +1,39 @@
+{ stdenv, fetchurl, pkgconfig, autoreconfHook, openssl, db48, boost
+, zlib, miniupnpc, qt4, utillinux, protobuf, qrencode, curl
+, withGui }:
+
+with stdenv.lib;
+stdenv.mkDerivation rec{
+
+  name = "bitcoin" + (toString (optional (!withGui) "d")) + "-xt-" + version;
+  xt_version = "0.11A";
+  version = xt_version;
+
+  src = fetchurl {
+    url = "https://github.com/bitcoinxt/bitcoinxt/archive/v0.11A.tar.gz";
+    sha256 = "129cbqf6bln6rhdk70c6nfwdjk6afvsaaw4xdyp0pnfand8idz7n";
+  };
+
+  buildInputs = [ pkgconfig autoreconfHook openssl db48 boost zlib
+                  miniupnpc utillinux protobuf curl ]
+                  ++ optionals withGui [ qt4 qrencode ];
+
+  configureFlags = [
+    "--with-boost-libdir=${boost.lib}/lib"
+    "--with-libcurl-headers=${curl}/include"
+  ] ++ optionals withGui [ "--with-gui=qt4" ];
+
+  meta = {
+    description = "Peer-to-peer electronic cash system";
+    longDescription= ''
+       Bitcoin XT is an implementation of a Bitcoin full node, based upon the
+       source code of Bitcoin Core. It is built by taking the latest stable
+       Core release, applying a series of patches, and then doing deterministic
+       builds so anyone can check the downloads correspond to the source code. 
+    '';
+    homepage = "https://bitcoinxt.software/";
+    maintainers = with maintainers; [ jefdaj ];
+    license = licenses.mit;
+    platforms = platforms.unix;
+  };
+}
diff --git a/pkgs/applications/altcoins/default.nix b/pkgs/applications/altcoins/default.nix
index a49e4dc9f909..762ef804f83e 100644
--- a/pkgs/applications/altcoins/default.nix
+++ b/pkgs/applications/altcoins/default.nix
@@ -5,6 +5,9 @@ rec {
   bitcoin  = callPackage ./bitcoin.nix { withGui = true; };
   bitcoind = callPackage ./bitcoin.nix { withGui = false; };
 
+  bitcoin-xt  = callPackage ./bitcoin-xt.nix { withGui = true; };
+  bitcoind-xt = callPackage ./bitcoin-xt.nix { withGui = false; };
+
   darkcoin  = callPackage ./darkcoin.nix { withGui = true; };
   darkcoind = callPackage ./darkcoin.nix { withGui = false; };
 
diff --git a/pkgs/applications/audio/petrifoo/default.nix b/pkgs/applications/audio/petrifoo/default.nix
index ffd920427ac5..c9d9ad57487a 100644
--- a/pkgs/applications/audio/petrifoo/default.nix
+++ b/pkgs/applications/audio/petrifoo/default.nix
@@ -1,6 +1,6 @@
 { stdenv, fetchurl, alsaLib, cmake, gtk, libjack2, libgnomecanvas
 , libpthreadstubs, libsamplerate, libsndfile, libtool, libxml2
-, pkgconfig }:
+, pkgconfig, openssl }:
 
 stdenv.mkDerivation  rec {
   name = "petri-foo-${version}";
@@ -13,7 +13,7 @@ stdenv.mkDerivation  rec {
 
   buildInputs =
    [ alsaLib cmake  gtk libjack2 libgnomecanvas libpthreadstubs
-     libsamplerate libsndfile libtool libxml2 pkgconfig
+     libsamplerate libsndfile libtool libxml2 pkgconfig openssl
    ];
 
   meta = with stdenv.lib; {
diff --git a/pkgs/applications/misc/calibre/default.nix b/pkgs/applications/misc/calibre/default.nix
index 7f8a42b077e9..abea6201e759 100644
--- a/pkgs/applications/misc/calibre/default.nix
+++ b/pkgs/applications/misc/calibre/default.nix
@@ -6,11 +6,11 @@
 
 stdenv.mkDerivation rec {
   name = "calibre-${version}";
-  version = "2.35.0";
+  version = "2.36.0";
 
   src = fetchurl {
     url = "https://github.com/kovidgoyal/calibre/releases/download/v${version}/${name}.tar.xz";
-    sha256 = "13sic0l16myvka8mgpr56h6qlpf1cwx8xlf4acp3qz6gsmz3r23x";
+    sha256 = "1my7fjj1lc28mhmvb85rcc4c5bwsycs6bgmafbx9agil5bgrbnb2";
   };
 
   inherit python;
diff --git a/pkgs/applications/misc/qtpass/default.nix b/pkgs/applications/misc/qtpass/default.nix
index 828019011fc4..e768a692f594 100644
--- a/pkgs/applications/misc/qtpass/default.nix
+++ b/pkgs/applications/misc/qtpass/default.nix
@@ -2,11 +2,11 @@
 
 stdenv.mkDerivation rec {
   name = "qtpass-${version}";
-  version = "0.8.4";
+  version = "1.0.1";
 
   src = fetchurl {
     url = "https://github.com/IJHack/qtpass/archive/v${version}.tar.gz";
-    sha256 = "14avh04q559p64ska1w814pbwv0742aaqln036pw99fjxav685g0";
+    sha256 = "1mmncvamvwr3hizc1jgpb5kscl9idmrfd2785jhwi87q11wjrwxz";
   };
 
   buildInputs = [ git gnupg makeWrapper pass qt5.base ];
diff --git a/pkgs/applications/misc/xca/0001-Fix-for-openssl-1.0.1i.patch b/pkgs/applications/misc/xca/0001-Fix-for-openssl-1.0.1i.patch
deleted file mode 100644
index 9bfe3831c4aa..000000000000
--- a/pkgs/applications/misc/xca/0001-Fix-for-openssl-1.0.1i.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From abd9d530776e8bb6d8f05312fc3ae3044796139c Mon Sep 17 00:00:00 2001
-From: Oliver Winker <oliver@oli1170.net>
-Date: Tue, 12 Aug 2014 19:08:05 +0200
-Subject: [PATCH] Fix for openssl 1.0.1i
-
-Fixes following application error
----
-Errors
-error:0D0C40D8:asn1 encoding routines:c2i_ASN1_OBJECT:invalid object encoding error:0D08303A:asn1 encoding routines:ASN1_TEMPLATE_NOEXP_D2I:nested asn1 error error:0D0C40D8:asn1 encoding routines:c2i_ASN1_OBJECT:invalid object encoding error:0D08303A:asn1 encoding routines:ASN1_TEMPLATE_NOEXP_D2I:nested asn1 error error:0D0C40D8:asn1 encoding routines:c2i_ASN1_OBJECT:invalid object encoding error:0D08303A:asn1 encoding routines:ASN1_TEMPLATE_NOEXP_D2I:nested asn1 error error:0D0C40D8:asn1 encoding routines:c2i_ASN1_OBJECT:invalid object encoding error:0D08303A:asn1 encoding routines:ASN1_TEMPLATE_NOEXP_D2I:nested asn1 error error:0D0C40D8:asn1 encoding routines:c2i_ASN1_OBJECT:invalid object encoding error:0D08303A:asn1 encoding routines:ASN1_TEMPLATE_NOEXP_D2I:nested asn1 error
----
-
-Due to openssl 1.0.1i change:
----
-commit 03b04ddac162c7b7fa3c57eadccc5a583a00d291
-Author: Emilia Kasper <emilia@openssl.org>
-Date:   Wed Jul 2 19:02:33 2014 +0200
-
-    Fix OID handling:
-
-    - Upon parsing, reject OIDs with invalid base-128 encoding.
-    - Always NUL-terminate the destination buffer in OBJ_obj2txt printing function.
-
-    CVE-2014-3508
-
-    Reviewed-by: Dr. Stephen Henson <steve@openssl.org>
-    Reviewed-by: Kurt Roeckx <kurt@openssl.org>
-    Reviewed-by: Tim Hudson <tjh@openssl.org>
----
----
- lib/x509v3ext.cpp | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/lib/x509v3ext.cpp b/lib/x509v3ext.cpp
-index cf74c32..d94cbda 100644
---- a/lib/x509v3ext.cpp
-+++ b/lib/x509v3ext.cpp
-@@ -27,6 +27,8 @@ x509v3ext::x509v3ext(const X509_EXTENSION *n)
- x509v3ext::x509v3ext(const x509v3ext &n)
- {
- 	ext = NULL;
-+	if (!n.isValid())
-+		return;
- 	set(n.ext);
- }
- 
-@@ -743,7 +745,7 @@ X509_EXTENSION *x509v3ext::get() const
- 
- bool x509v3ext::isValid() const
- {
--	return ext->value->length > 0 &&
-+	return ext && ext->value && ext->value->length > 0 &&
- 		OBJ_obj2nid(ext->object) != NID_undef;
- }
- 
--- 
-2.0.1
-
diff --git a/pkgs/applications/misc/xca/default.nix b/pkgs/applications/misc/xca/default.nix
index d5fa5e5ec56d..fdd136cc8389 100644
--- a/pkgs/applications/misc/xca/default.nix
+++ b/pkgs/applications/misc/xca/default.nix
@@ -2,21 +2,13 @@
 
 stdenv.mkDerivation rec {
   name = "xca-${version}";
-  version = "0.9.3";
+  version = "1.3.0";
 
   src = fetchurl {
     url = "mirror://sourceforge/xca/${name}.tar.gz";
-    sha256 = "1fn6kh8mdy65rrgjif7j9wn3mxg1mrrcnhzpi86hfy24ic6bahk8";
+    sha256 = "0k21d4lfkn0nlj8az6067dmc5dgy5cidspljagmh5frsv576wnzg";
   };
 
-  patches = [ ./0001-Fix-for-openssl-1.0.1i.patch ];
-
-  configurePhase = ''
-    export PATH=$PATH:${which}/bin
-    export QTDIR=${qt4}
-    prefix=$out ./configure ${openssl} ${libtool}
-  '';
-
   postInstall = ''
     wrapProgram "$out/bin/xca" \
       --prefix LD_LIBRARY_PATH : "${qt4}/lib:${gcc.cc}/lib:${gcc.cc}/lib64:${openssl}/lib:${libtool}/lib"
diff --git a/pkgs/applications/science/programming/kframework/default.nix b/pkgs/applications/science/programming/kframework/default.nix
deleted file mode 100644
index e8a4f2b31564..000000000000
--- a/pkgs/applications/science/programming/kframework/default.nix
+++ /dev/null
@@ -1,102 +0,0 @@
-{ stdenv, fetchFromGitHub, maven, openjdk8, releaseTools }:
-
-# TODO:
-# - Investigate builds on platforms other than 64-bit linux
-# - Separate package for Maven cache? This would speed up builds and
-#   theoretically could still be pure
-# - Find a way to prevent Maven from downloading artifacts irrelevant
-#   to the platform for which we are building
-
-releaseTools.mvnBuild rec {
-  name = "kframework-20150415";
-
-  mvn8 = maven.override {
-    jdk = openjdk8; # K uses Java 8. The official docs reference the
-                    # Oracle VM, but it's been working with OpenJDK
-  };
-
-  src = fetchFromGitHub {
-    owner = "kframework";
-    repo = "k";
-    rev = "85a41bc024"; # nightly build for April 15th, 2015
-    sha256 = "01ndfdnqxp2w86pg3ax39sxayb2pfm39lj1h3818zzn86gqwa1vc";
-  };
-
-  buildInputs = [ mvn8 openjdk8 ];
-
-  preSetupPhase = ''
-    # z3 needs this to pass tests
-    export LD_LIBRARY_PATH=$(cat $NIX_CC/nix-support/orig-cc)/lib
-    # not sure if this does anything, since it might only speed up incremental builds
-    export MAVEN_OPTS="-XX:+TieredCompilation"
-  '';
-
-  mvnAssembly = ''
-    mvn package -Dcheckstyle.skip -Dmaven.test.skip=true -Dmaven.repo.local=$M2_REPO
-  '';
-
-  mvnRelease = ''
-    true # do nothing, since mvn package is sufficient
-  '';
-
-  # this is a custom version of k-distribution/src/main/scripts/lib/k
-  kscript = ''
-    #!/usr/bin/env bash
-    export JAVA=${openjdk8}/bin/java
-
-    export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:"$out/lib"
-
-    export K_OPTS="-Xms64m -Xmx1024m -Xss32m -XX:+TieredCompilation"
-    export MISC_ARGS="-Djava.awt.headless=true"
-    export ARGS="$MISC_ARGS $K_OPTS"
-    $JAVA $ARGS -cp "$out/share/kframework/lib/java/*" org.kframework.main.Main "$@"
-  '';
-
-  finalPhase = ''
-    # set some environment variables
-    export K_ROOT=$PWD/k-distribution/target/release/k/
-    export K_SHARE=$out/share/kframework/
-    # make requisite directories
-    mkdir -p $out/lib $K_SHARE/lib/native
-    # copy over bin
-    cp -R $K_ROOT/bin                             $K_SHARE/
-    # symlink $out/bin to $out/share/kframework/bin
-    ln -s $K_SHARE/bin                            $out/bin
-    # copy everything relevant to $out/share/kframework
-    # we may want to consider adding the documentation etc.
-    cp -R $K_ROOT/include                         $K_SHARE/
-    cp -R $K_ROOT/lib/java                        $K_SHARE/lib/
-    cp -R $K_ROOT/lib/native/linux                $K_SHARE/lib/native/
-    cp -R $K_ROOT/lib/native/linux64              $K_SHARE/lib/native/
-    # remove Windows batch scripts
-    rm $K_SHARE/bin/*.bat # */
-    # TODO: fix these scripts so they work
-    rm $K_SHARE/bin/kserver $K_SHARE/bin/stop-kserver
-    # make our k wrapper script and substitute $out for its value
-    echo -n "$kscript" | sed "s:\$out:$out:g" > $K_SHARE/lib/k
-    chmod +x $K_SHARE/lib/k
-    # symlink requisite binaries
-    ln -s $K_SHARE/lib/k                           $out/lib/k
-    ln -s $K_SHARE/lib/native/linux/sdf2table      $out/bin/sdf2table
-    ln -s $K_SHARE/lib/native/linux64/z3           $out/bin/z3
-    ln -s $K_SHARE/lib/native/linux64/libz3.so     $out/lib/libz3.so
-    ln -s $K_SHARE/lib/native/linux64/libz3java.so $out/lib/libz3java.so
-    # patch Z3 so it uses the right interpreter/libs
-    patchelf \
-      --interpreter "$(cat $NIX_CC/nix-support/dynamic-linker)" \
-      --set-rpath $(cat $NIX_CC/nix-support/orig-cc)/lib \
-      --force-rpath \
-      $K_SHARE/lib/native/linux64/z3
-  '';
-
-  meta = {
-    description = "A rewrite-based executable semantic framework in which programming languages, type systems and formal analysis tools can be defined";
-    homepage = http://www.kframework.org;
-    license = stdenv.lib.licenses.bsd3;     # technically it is the UIUC/NCSA license
-                                            # but LLVM uses that license as well and
-                                            # it is marked as BSD3
-    maintainers = [ stdenv.lib.maintainers.taktoa ];
-    platforms = stdenv.lib.platforms.linux; # I haven't done testing on other OSes, but
-                                            # since it's Java it should run anywhere
-  };
-}
diff --git a/pkgs/applications/science/spyder/default.nix b/pkgs/applications/science/spyder/default.nix
index 806d2f546cf5..c068847c331b 100644
--- a/pkgs/applications/science/spyder/default.nix
+++ b/pkgs/applications/science/spyder/default.nix
@@ -8,12 +8,13 @@
 }:
 
 buildPythonPackage rec {
-  name = "spyder-2.2.5";
+  name = "spyder-${version}";
+  version = "2.3.6";
   namePrefix = "";
 
   src = fetchurl {
-    url = "https://spyderlib.googlecode.com/files/${name}.zip";
-    sha256 = "1bxc5qs2bqc21s6kxljsfxnmwgrgnyjfr9mkwzg9njpqsran3bp2";
+    url = "https://pypi.python.org/packages/source/s/spyder/${name}.zip";
+    sha256 = "0e6502e0d3f270ea8916d1a3d7ca29915801d31932db399582bc468c01d535e2";
   };
 
   buildInputs = [ unzip ];
@@ -23,6 +24,11 @@ buildPythonPackage rec {
   # There is no test for spyder
   doCheck = false;
 
+  # Use setuptools instead of distutils.
+  preConfigure = ''
+    export USE_SETUPTOOLS=True
+  '';
+
   desktopItem = makeDesktopItem {
     name = "Spyder";
     exec = "spyder";
@@ -49,7 +55,7 @@ buildPythonPackage rec {
       environment for the Python language with advanced editing, interactive
       testing, debugging and introspection features.
     '';
-    homepage = https://code.google.com/p/spyderlib/;
+    homepage = https://github.com/spyder-ide/spyder/;
     license = licenses.mit;
     platforms = platforms.linux;
     maintainers = [ maintainers.bjornfor ];
diff --git a/pkgs/applications/version-management/cvs-fast-export/default.nix b/pkgs/applications/version-management/cvs-fast-export/default.nix
index 15035a345d4e..62a58ee985c0 100644
--- a/pkgs/applications/version-management/cvs-fast-export/default.nix
+++ b/pkgs/applications/version-management/cvs-fast-export/default.nix
@@ -30,6 +30,7 @@ mkDerivation rec {
   preBuild = ''
     makeFlagsArray=(
       XML_CATALOG_FILES="${docbook_xml_dtd_45}/xml/dtd/docbook/catalog.xml ${docbook_xml_xslt}/xml/xsl/docbook/catalog.xml"
+      LIBS=""
       prefix="$out"
     )
   '';
diff --git a/pkgs/applications/virtualization/docker/default.nix b/pkgs/applications/virtualization/docker/default.nix
index 6ad59a087e9f..2363ccd910b1 100644
--- a/pkgs/applications/virtualization/docker/default.nix
+++ b/pkgs/applications/virtualization/docker/default.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchFromGitHub, makeWrapper, go, lxc, sqlite, iproute, bridge-utils, devicemapper,
-btrfsProgs, iptables, bash, e2fsprogs, xz}:
+btrfsProgs, iptables, bash, e2fsprogs, xz, utillinux}:
 
 # https://github.com/docker/docker/blob/master/project/PACKAGERS.md
 
@@ -33,7 +33,7 @@ stdenv.mkDerivation rec {
   installPhase = ''
     install -Dm755 ./bundles/${version}/dynbinary/docker-${version} $out/libexec/docker/docker
     install -Dm755 ./bundles/${version}/dynbinary/dockerinit-${version} $out/libexec/docker/dockerinit
-    makeWrapper $out/libexec/docker/docker $out/bin/docker --prefix PATH : "${iproute}/sbin:sbin:${lxc}/bin:${iptables}/sbin:${e2fsprogs}/sbin:${xz}/bin"
+    makeWrapper $out/libexec/docker/docker $out/bin/docker --prefix PATH : "${iproute}/sbin:sbin:${lxc}/bin:${iptables}/sbin:${e2fsprogs}/sbin:${xz}/bin:${utillinux}/bin"
 
     # systemd
     install -Dm644 ./contrib/init/systemd/docker.service $out/etc/systemd/system/docker.service