summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2014-04-19 15:16:22 +0200
committeraszlig <aszlig@redmoonstudios.org>2014-04-20 17:45:25 +0200
commitad770bea6789a14dbad6178d3c5e39775d1e5d55 (patch)
tree41355287423d834eecaee2d29bc01978fa33e85d /pkgs/applications
parentc537fa6da03a484081d51998013fef9b9a037283 (diff)
downloadnixlib-ad770bea6789a14dbad6178d3c5e39775d1e5d55.tar
nixlib-ad770bea6789a14dbad6178d3c5e39775d1e5d55.tar.gz
nixlib-ad770bea6789a14dbad6178d3c5e39775d1e5d55.tar.bz2
nixlib-ad770bea6789a14dbad6178d3c5e39775d1e5d55.tar.lz
nixlib-ad770bea6789a14dbad6178d3c5e39775d1e5d55.tar.xz
nixlib-ad770bea6789a14dbad6178d3c5e39775d1e5d55.tar.zst
nixlib-ad770bea6789a14dbad6178d3c5e39775d1e5d55.zip
chromium: Move update.sh back into the main path.
This is to ensure that nothing unexpected will be after the merge of the
refactoring branch, and also my own autoupdate machinery is expecting
this location, so there really is no reason to change it now.

Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/browsers/chromium/source/sources.nix2
-rwxr-xr-xpkgs/applications/networking/browsers/chromium/update.sh (renamed from pkgs/applications/networking/browsers/chromium/source/update.sh)4
2 files changed, 3 insertions, 3 deletions
diff --git a/pkgs/applications/networking/browsers/chromium/source/sources.nix b/pkgs/applications/networking/browsers/chromium/source/sources.nix
index 9204c7f08e5b..6881b8d44e84 100644
--- a/pkgs/applications/networking/browsers/chromium/source/sources.nix
+++ b/pkgs/applications/networking/browsers/chromium/source/sources.nix
@@ -1,4 +1,4 @@
-# This file is autogenerated from update.sh in the same directory.
+# This file is autogenerated from update.sh in the parent directory.
 {
   dev = {
     version = "36.0.1941.0";
diff --git a/pkgs/applications/networking/browsers/chromium/source/update.sh b/pkgs/applications/networking/browsers/chromium/update.sh
index 806169f524c3..e82d22f34fd0 100755
--- a/pkgs/applications/networking/browsers/chromium/source/update.sh
+++ b/pkgs/applications/networking/browsers/chromium/update.sh
@@ -3,7 +3,7 @@
 channels_url="http://omahaproxy.appspot.com/all?csv=1";
 history_url="http://omahaproxy.appspot.com/history";
 bucket_url="http://commondatastorage.googleapis.com/chromium-browser-official/";
-base_path="$(cd "$(dirname "$0")" && pwd)";
+base_path="$(cd "$(dirname "$0")" && pwd)/source";
 
 source "$(nix-build --no-out-link "$base_path/update.nix" -A updateHelpers)";
 
@@ -116,7 +116,7 @@ versions="$(echo "$omaha" | sed -nr -e 's/^linux,([^,]+,[^,]+).*$/\1/p')";
 channel_exprs="$(get_channel_exprs "$versions")";
 
 cat > "$base_path/sources.nix" <<-EOF
-# This file is autogenerated from update.sh in the same directory.
+# This file is autogenerated from update.sh in the parent directory.
 {
 $channel_exprs
 }