summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorPaul Colomiets <paul@colomiets.name>2014-06-29 02:16:19 +0300
committerBjørn Forsman <bjorn.forsman@gmail.com>2014-07-15 14:59:16 +0200
commitabf19df497806892678c1395feae1c9d065cbe24 (patch)
tree7daf8e9324642b60593987a083624807249ed8f6 /pkgs/applications
parent8d9ff87c14a35a28ef902871f99fa45cfa0a8397 (diff)
downloadnixlib-abf19df497806892678c1395feae1c9d065cbe24.tar
nixlib-abf19df497806892678c1395feae1c9d065cbe24.tar.gz
nixlib-abf19df497806892678c1395feae1c9d065cbe24.tar.bz2
nixlib-abf19df497806892678c1395feae1c9d065cbe24.tar.lz
nixlib-abf19df497806892678c1395feae1c9d065cbe24.tar.xz
nixlib-abf19df497806892678c1395feae1c9d065cbe24.tar.zst
nixlib-abf19df497806892678c1395feae1c9d065cbe24.zip
Remove wrapVim
I don't see a reason for having wrapVim function and vimWrapper and
vimHugeXWrapper packages. If you need a system vimrc, whats wrong with
``environment.etc."vimrc".text`` ?

Also strictly speaking ``vimHugeXWrapper`` didn't wrap, X-version
properly. I.e. running ``gvim`` have console vim version.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/vim/wrapper.nix32
1 files changed, 0 insertions, 32 deletions
diff --git a/pkgs/applications/editors/vim/wrapper.nix b/pkgs/applications/editors/vim/wrapper.nix
deleted file mode 100644
index 72e868050537..000000000000
--- a/pkgs/applications/editors/vim/wrapper.nix
+++ /dev/null
@@ -1,32 +0,0 @@
-{ stdenv, makeWrapper, writeText, vim, vimrc }:
-
-let
-
-  vimrcfile = writeText "vimrc" vimrc;
-
-  p = builtins.parseDrvName vim.name;
-
-in stdenv.mkDerivation rec {
-  name = "${p.name}-with-vimrc-${p.version}";
-
-  buildInputs = [ makeWrapper vim vimrcfile ];
-
-  phases = [ "installPhase" ];
-
-  installPhase = ''
-    mkdir -p $out
-    cp -r ${vim}/* $out/
-
-    chmod u+w $out/bin
-    chmod u+w $out/share/vim
-
-    ln -s ${vimrcfile} $out/share/vim/vimrc
-    wrapProgram $out/bin/vim --set VIM "$out/share/vim"
-  '';
-
-  meta = with stdenv.lib; {
-    description = "The most popular clone of the VI editor";
-    homepage    = http://www.vim.org;
-    platforms   = platforms.unix;
-  };
-}