summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorFlorian Friesdorf <flo@chaoflow.net>2012-01-21 18:28:54 +0000
committerFlorian Friesdorf <flo@chaoflow.net>2012-01-21 18:28:54 +0000
commitaa277f7d06b979c85d516b1dc75901f93f8809dd (patch)
treeb7b03eefa7c842e6916bd2c7401a7dfb0c5c9a40 /pkgs/applications
parent2d0a86d05737d0ecb38f0461a5a42e3356f03579 (diff)
downloadnixlib-aa277f7d06b979c85d516b1dc75901f93f8809dd.tar
nixlib-aa277f7d06b979c85d516b1dc75901f93f8809dd.tar.gz
nixlib-aa277f7d06b979c85d516b1dc75901f93f8809dd.tar.bz2
nixlib-aa277f7d06b979c85d516b1dc75901f93f8809dd.tar.lz
nixlib-aa277f7d06b979c85d516b1dc75901f93f8809dd.tar.xz
nixlib-aa277f7d06b979c85d516b1dc75901f93f8809dd.tar.zst
nixlib-aa277f7d06b979c85d516b1dc75901f93f8809dd.zip
emacs-23 as base for emacs-24
svn path=/nixpkgs/trunk/; revision=31762
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/emacs-24/builder.sh34
-rw-r--r--pkgs/applications/editors/emacs-24/default.nix72
2 files changed, 106 insertions, 0 deletions
diff --git a/pkgs/applications/editors/emacs-24/builder.sh b/pkgs/applications/editors/emacs-24/builder.sh
new file mode 100644
index 000000000000..d04e7a4fdd3f
--- /dev/null
+++ b/pkgs/applications/editors/emacs-24/builder.sh
@@ -0,0 +1,34 @@
+source $stdenv/setup
+
+# This hook is supposed to be run on Linux. It patches the proper locations of
+# the crt{1,i,n}.o files into the build to ensure that Emacs is linked with
+# *our* versions, not the ones found in the system, as it would do by default.
+# On other platforms, this appears to be unnecessary.
+preConfigure() {
+    case "${system}" in
+	x86_64-linux)	glibclibdir=lib64 ;;
+	i686-linux)	glibclibdir=lib ;;
+        *)              return;
+    esac
+
+    libc=$(cat ${NIX_GCC}/nix-support/orig-libc)
+    echo "libc: $libc"
+
+    for i in src/s/*.h src/m/*.h; do
+        substituteInPlace $i \
+            --replace /usr/${glibclibdir}/crt1.o $libc/${glibclibdir}/crt1.o \
+            --replace /usr/${glibclibdir}/crti.o $libc/${glibclibdir}/crti.o \
+            --replace /usr/${glibclibdir}/crtn.o $libc/${glibclibdir}/crtn.o \
+            --replace /usr/lib/crt1.o $libc/${glibclibdir}/crt1.o \
+            --replace /usr/lib/crti.o $libc/${glibclibdir}/crti.o \
+            --replace /usr/lib/crtn.o $libc/${glibclibdir}/crtn.o
+    done
+
+    for i in Makefile.in ./src/Makefile.in ./lib-src/Makefile.in ./leim/Makefile.in; do
+        substituteInPlace $i --replace /bin/pwd pwd
+    done
+}
+
+preBuild="make bootstrap"
+
+genericBuild
diff --git a/pkgs/applications/editors/emacs-24/default.nix b/pkgs/applications/editors/emacs-24/default.nix
new file mode 100644
index 000000000000..84a98182e9f5
--- /dev/null
+++ b/pkgs/applications/editors/emacs-24/default.nix
@@ -0,0 +1,72 @@
+{ stdenv, fetchurl, ncurses, x11, libXaw, libXpm, Xaw3d
+, pkgconfig, gtk, libXft, dbus, libpng, libjpeg, libungif
+, libtiff, librsvg, texinfo, gconf
+}:
+
+assert (gtk != null) -> (pkgconfig != null);
+assert (libXft != null) -> libpng != null;	# probably a bug
+assert stdenv.isDarwin -> libXaw != null;	# fails to link otherwise
+
+stdenv.mkDerivation rec {
+  name = "emacs-23.3";
+
+  builder = ./builder.sh;
+
+  src = fetchurl {
+    url = "mirror://gnu/emacs/${name}.tar.bz2";
+    sha256 = "0kfa546qi0idkwk29gclgi13qd8q54pcqgy9qwjknlclszprdp3a";
+  };
+
+  buildInputs = 
+    [ ncurses x11 texinfo libXaw Xaw3d libXpm libpng libjpeg libungif
+      libtiff librsvg libXft gconf
+    ] 
+    ++ stdenv.lib.optionals (gtk != null) [ gtk pkgconfig ]
+    ++ stdenv.lib.optional stdenv.isLinux dbus;
+
+  configureFlags =
+    stdenv.lib.optionals (gtk != null) [ "--with-x-toolkit=gtk" "--with-xft"]
+
+    # On NixOS, help Emacs find `crt*.o'.
+    ++ stdenv.lib.optional (stdenv ? glibc)
+         [ "--with-crt-dir=${stdenv.glibc}/lib" ];
+
+  postInstall = ''
+    cat >$out/share/emacs/site-lisp/site-start.el <<EOF
+;; nixos specific load-path
+(when (getenv "NIX_PROFILES") (setq load-path
+                      (append (reverse (mapcar (lambda (x) (concat x "/share/emacs/site-lisp/"))
+                                               (split-string (getenv "NIX_PROFILES"))))
+                       load-path)))
+EOF
+  '';
+
+  doCheck = true;
+
+  meta = {
+    description = "GNU Emacs 23.x, the extensible, customizable text editor";
+
+    longDescription = ''
+      GNU Emacs is an extensible, customizable text editor—and more.  At its
+      core is an interpreter for Emacs Lisp, a dialect of the Lisp
+      programming language with extensions to support text editing.
+
+      The features of GNU Emacs include: content-sensitive editing modes,
+      including syntax coloring, for a wide variety of file types including
+      plain text, source code, and HTML; complete built-in documentation,
+      including a tutorial for new users; full Unicode support for nearly all
+      human languages and their scripts; highly customizable, using Emacs
+      Lisp code or a graphical interface; a large number of extensions that
+      add other functionality, including a project planner, mail and news
+      reader, debugger interface, calendar, and more.  Many of these
+      extensions are distributed with GNU Emacs; others are available
+      separately.
+    '';
+
+    homepage = http://www.gnu.org/software/emacs/;
+    license = "GPLv3+";
+
+    maintainers = with stdenv.lib.maintainers; [ ludo simons chaoflow ];
+    platforms = stdenv.lib.platforms.all;
+  };
+}