summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorGabriel Ebner <gebner@gebner.org>2017-12-30 21:16:16 +0100
committerGabriel Ebner <gebner@gebner.org>2017-12-30 21:16:16 +0100
commita9f118914fe57ae6b45719717157878037d98373 (patch)
tree243cd71c43e4e90fcb39c4362eb58f3e163dc551 /pkgs/applications
parent9db8e2267992aae505aebbeac193078022c523aa (diff)
downloadnixlib-a9f118914fe57ae6b45719717157878037d98373.tar
nixlib-a9f118914fe57ae6b45719717157878037d98373.tar.gz
nixlib-a9f118914fe57ae6b45719717157878037d98373.tar.bz2
nixlib-a9f118914fe57ae6b45719717157878037d98373.tar.lz
nixlib-a9f118914fe57ae6b45719717157878037d98373.tar.xz
nixlib-a9f118914fe57ae6b45719717157878037d98373.tar.zst
nixlib-a9f118914fe57ae6b45719717157878037d98373.zip
electrum: enable support for qr codes
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/electrum/default.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/pkgs/applications/misc/electrum/default.nix b/pkgs/applications/misc/electrum/default.nix
index a339770ba588..10f12885dcd8 100644
--- a/pkgs/applications/misc/electrum/default.nix
+++ b/pkgs/applications/misc/electrum/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, python3, python3Packages }:
+{ stdenv, fetchurl, python3, python3Packages, zbar }:
 
 python3Packages.buildPythonApplication rec {
   name = "electrum-${version}";
@@ -38,6 +38,7 @@ python3Packages.buildPythonApplication rec {
     pyrcc5 icons.qrc -o gui/qt/icons_rc.py
     # Recording the creation timestamps introduces indeterminism to the build
     sed -i '/Created: .*/d' gui/qt/icons_rc.py
+    sed -i "s|name = 'libzbar.*'|name='${zbar}/lib/libzbar.so'|" lib/qrscanner.py
   '';
 
   postInstall = ''