summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorArseniy Seroka <jagajaga@users.noreply.github.com>2015-08-04 17:14:35 +0300
committerArseniy Seroka <jagajaga@users.noreply.github.com>2015-08-04 17:14:35 +0300
commita75c725fd4c971ec92ffd546e76c23269d428ae2 (patch)
treeeaf4a651ac2834e13dada2a29470ef77384752b9 /pkgs/applications
parentd649a1d88f2126cc2da47368a9235485e61170d2 (diff)
parent582ecf47711c60c28d554b42f60af2711578c76b (diff)
downloadnixlib-a75c725fd4c971ec92ffd546e76c23269d428ae2.tar
nixlib-a75c725fd4c971ec92ffd546e76c23269d428ae2.tar.gz
nixlib-a75c725fd4c971ec92ffd546e76c23269d428ae2.tar.bz2
nixlib-a75c725fd4c971ec92ffd546e76c23269d428ae2.tar.lz
nixlib-a75c725fd4c971ec92ffd546e76c23269d428ae2.tar.xz
nixlib-a75c725fd4c971ec92ffd546e76c23269d428ae2.tar.zst
nixlib-a75c725fd4c971ec92ffd546e76c23269d428ae2.zip
Merge pull request #7954 from qknight/inkscape_boxmaker
inkscape with boxmaker plugin
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/graphics/inkscape/default.nix26
1 files changed, 24 insertions, 2 deletions
diff --git a/pkgs/applications/graphics/inkscape/default.nix b/pkgs/applications/graphics/inkscape/default.nix
index 41531ed0de84..409fd0a767ce 100644
--- a/pkgs/applications/graphics/inkscape/default.nix
+++ b/pkgs/applications/graphics/inkscape/default.nix
@@ -2,9 +2,20 @@
 , libpng, zlib, popt, boehmgc, libxml2, libxslt, glib, gtkmm
 , glibmm, libsigcxx, lcms, boost, gettext, makeWrapper, intltool
 , gsl, python, pyxml, lxml, poppler, imagemagick, libwpg, librevenge
-, libvisio, libcdr, libexif
+, libvisio, libcdr, libexif, unzip
+, boxMakerPlugin ? false # boxmaker plugin
 }:
 
+let 
+
+boxmaker = fetchurl {
+  # http://www.inkscapeforum.com/viewtopic.php?f=11&t=10403
+  url = "http://www.keppel.demon.co.uk/111000/files/BoxMaker0.91.zip";
+  sha256 = "5c5697f43dc3a95468f61f479cb50b7e2b93379a1729abf19e4040ac9f43a1a8";
+};
+
+in
+
 stdenv.mkDerivation rec {
   name = "inkscape-0.91";
 
@@ -34,12 +45,23 @@ stdenv.mkDerivation rec {
     libxml2 libxslt glib gtkmm glibmm libsigcxx lcms boost gettext
     makeWrapper intltool gsl poppler imagemagick libwpg librevenge
     libvisio libcdr libexif
-  ];
+  ] ++ stdenv.lib.optional boxMakerPlugin unzip;
 
   enableParallelBuilding = true;
   doCheck = true;
 
   postInstall = ''
+    ${if boxMakerPlugin then "
+      mkdir -p $out/share/inkscape/extensions/
+      # boxmaker packaged version 0.91 in a directory called 0.85 ?!??
+      unzip ${boxmaker};
+      cp boxmake-upd-0.85/* $out/share/inkscape/extensions/
+      rm -Rf boxmake-upd-0.85
+      "
+    else 
+      ""
+    }
+
     # Make sure PyXML modules can be found at run-time.
     for i in "$out/bin/"*
     do