summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJoachim Fasting <joachifm@fastmail.fm>2015-04-17 22:11:03 +0200
committerJoachim Fasting <joachifm@fastmail.fm>2015-04-24 11:54:34 +0200
commita579886b2b04908bb0bc95b751bf0e7e3ffeb59d (patch)
treea0d88b29fb6026f7073682add6a87f90be53c362 /pkgs/applications
parentfd9c13956f2e728249421d79f2a71a3e987b5aa2 (diff)
downloadnixlib-a579886b2b04908bb0bc95b751bf0e7e3ffeb59d.tar
nixlib-a579886b2b04908bb0bc95b751bf0e7e3ffeb59d.tar.gz
nixlib-a579886b2b04908bb0bc95b751bf0e7e3ffeb59d.tar.bz2
nixlib-a579886b2b04908bb0bc95b751bf0e7e3ffeb59d.tar.lz
nixlib-a579886b2b04908bb0bc95b751bf0e7e3ffeb59d.tar.xz
nixlib-a579886b2b04908bb0bc95b751bf0e7e3ffeb59d.tar.zst
nixlib-a579886b2b04908bb0bc95b751bf0e7e3ffeb59d.zip
vue: reimplement using mkDerivation
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/vue/default.nix55
1 files changed, 16 insertions, 39 deletions
diff --git a/pkgs/applications/misc/vue/default.nix b/pkgs/applications/misc/vue/default.nix
index 5133ad3c29eb..c338a101563e 100644
--- a/pkgs/applications/misc/vue/default.nix
+++ b/pkgs/applications/misc/vue/default.nix
@@ -1,50 +1,27 @@
-x@{builderDefsPackage
-  , jre, unzip
-  , ...}:
-builderDefsPackage
-(a :
-let
-  helperArgNames = ["stdenv" "fetchurl" "builderDefsPackage"] ++
-    [];
+{ stdenv, fetchurl, jre }:
 
-  buildInputs = map (n: builtins.getAttr n x)
-    (builtins.attrNames (builtins.removeAttrs x helperArgNames));
-  sourceInfo = rec {
-    baseName="vue";
-    version="3.2.2";
-    name="${baseName}-${version}";
-    url="releases.atech.tufts.edu/jenkins/job/VUE/64/deployedArtifacts/download/artifact.2";
-    hash="0sb1kgan8fvph2cqfxk3906cwx5wy83zni2vlz4zzi6yg4zvfxld";
+stdenv.mkDerivation rec {
+  name = "vue-${version}";
+  version = "3.2.2";
+  src = fetchurl {
+    url = "releases.atech.tufts.edu/jenkins/job/VUE/64/deployedArtifacts/download/artifact.2";
+    sha256 = "0sb1kgan8fvph2cqfxk3906cwx5wy83zni2vlz4zzi6yg4zvfxld";
   };
-in
-rec {
-  src = a.fetchurl {
-    url = sourceInfo.url;
-    sha256 = sourceInfo.hash;
-  };
-
-  inherit (sourceInfo) name version;
-  inherit buildInputs;
 
-  /* doConfigure should be removed if not needed */
-  phaseNames = ["doDeploy"];
+  phases = "installPhase";
 
-  doDeploy = a.fullDepEntry ''
+  installPhase = ''
     mkdir -p "$out"/{share/vue,bin}
     cp ${src} "$out/share/vue/vue.jar"
-    echo '#!${a.stdenv.shell}' >> "$out/bin/vue"
-    echo '${a.jre}/bin/java -jar "'"$out/share/vue/vue.jar"'" "$@"' >> "$out/bin/vue"
+    echo '#!${stdenv.shell}' >> "$out/bin/vue"
+    echo '${jre}/bin/java -jar "'"$out/share/vue/vue.jar"'" "$@"' >> "$out/bin/vue"
     chmod a+x "$out/bin/vue"
-  '' ["addInputs" "defEnsureDir"];
+  '';
 
   meta = {
     description = "Visual Understanding Environment - mind mapping software";
-    maintainers = with a.lib.maintainers;
-    [
-      raskin
-    ];
-    platforms = with a.lib.platforms;
-      linux;
-    license = a.lib.licenses.free; # Apache License fork, actually
+    maintainers = with stdenv.lib.maintainers; [ raskin ];
+    platforms = with stdenv.lib.platforms; linux;
+    license = stdenv.lib.licenses.free; # Apache License fork, actually
   };
-}) x
+}