summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorkoral <koral@mailoo.org>2016-01-16 16:03:18 +0100
committerkoral <koral@mailoo.org>2016-01-16 16:03:18 +0100
commit9ed945784630b5c3cfcae5fdba04c88fb4286a60 (patch)
tree004869b79277b2278283812992b33c540033e360 /pkgs/applications
parent26f221d6b62b24d48f79f22e7f12bb6ff10580da (diff)
downloadnixlib-9ed945784630b5c3cfcae5fdba04c88fb4286a60.tar
nixlib-9ed945784630b5c3cfcae5fdba04c88fb4286a60.tar.gz
nixlib-9ed945784630b5c3cfcae5fdba04c88fb4286a60.tar.bz2
nixlib-9ed945784630b5c3cfcae5fdba04c88fb4286a60.tar.lz
nixlib-9ed945784630b5c3cfcae5fdba04c88fb4286a60.tar.xz
nixlib-9ed945784630b5c3cfcae5fdba04c88fb4286a60.tar.zst
nixlib-9ed945784630b5c3cfcae5fdba04c88fb4286a60.zip
lemonbar: 1.1 -> 1.2pre
'bar' has been officially renamed 'lemonbar'.
Last release (1.1) is almost a year old, but some bugfixes and new features are available in the repository, let's include them in the derivation.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/window-managers/bar/default.nix25
-rw-r--r--pkgs/applications/window-managers/lemonbar/default.nix27
-rw-r--r--pkgs/applications/window-managers/lemonbar/xft.nix (renamed from pkgs/applications/window-managers/bar/xft.nix)0
3 files changed, 27 insertions, 25 deletions
diff --git a/pkgs/applications/window-managers/bar/default.nix b/pkgs/applications/window-managers/bar/default.nix
deleted file mode 100644
index 964390d3b59b..000000000000
--- a/pkgs/applications/window-managers/bar/default.nix
+++ /dev/null
@@ -1,25 +0,0 @@
-{ stdenv, fetchurl, perl, libxcb }:
-
-let
-  version = "1.1";
-in
-  stdenv.mkDerivation rec {
-    name = "bar-${version}";
-  
-    src = fetchurl {
-      url = "https://github.com/LemonBoy/bar/archive/v${version}.tar.gz";
-      sha256 = "171ciw676cvj80zzbqfbg9nwix36zph0683zmqf279q9b9bmayan";
-    };
-  
-    buildInputs = [ libxcb perl ];
-  
-    prePatch = ''sed -i "s@/usr@$out@" Makefile'';
-  
-    meta = {
-      description = "A lightweight xcb based bar";
-      homepage = https://github.com/LemonBoy/bar;
-      maintainers = [ stdenv.lib.maintainers.meisternu ];
-      license = "Custom";   
-      platforms = stdenv.lib.platforms.linux;
-    };
-}
diff --git a/pkgs/applications/window-managers/lemonbar/default.nix b/pkgs/applications/window-managers/lemonbar/default.nix
new file mode 100644
index 000000000000..042abf09dad2
--- /dev/null
+++ b/pkgs/applications/window-managers/lemonbar/default.nix
@@ -0,0 +1,27 @@
+{ stdenv, fetchFromGitHub, perl, libxcb }:
+
+let
+  version = "1.2pre";
+in
+  stdenv.mkDerivation rec {
+    name = "lemonbar-${version}";
+  
+    src = fetchFromGitHub {
+      owner = "LemonBoy";
+      repo = "bar";
+      rev = "61985278f2af1e4e85d63a696ffedc5616b06bc0";
+      sha256 = "0a8djlayimjdg5fj50lpifsv6gkb577bca68wmk9wg9y9n27pgay";
+    };
+  
+    buildInputs = [ libxcb perl ];
+  
+    prePatch = ''sed -i "s@/usr@$out@" Makefile'';
+  
+    meta = with stdenv.lib; {
+      description = "A lightweight xcb based bar";
+      homepage = https://github.com/LemonBoy/bar;
+      maintainers = [ maintainers.meisternu ];
+      license = "Custom";   
+      platforms = platforms.linux;
+    };
+}
diff --git a/pkgs/applications/window-managers/bar/xft.nix b/pkgs/applications/window-managers/lemonbar/xft.nix
index c671f1a4e037..c671f1a4e037 100644
--- a/pkgs/applications/window-managers/bar/xft.nix
+++ b/pkgs/applications/window-managers/lemonbar/xft.nix