summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2018-06-21 11:09:36 +0100
committerJörg Thalheim <joerg@thalheim.io>2018-06-21 11:11:41 +0100
commit9da836dd039195f0c2682adbd97fe1997644e895 (patch)
tree59184cea9a2a175e1c6b82ac8292e08cb70ab137 /pkgs/applications
parenteb16ff918e327c05894672ea0fb95ad6c3237641 (diff)
downloadnixlib-9da836dd039195f0c2682adbd97fe1997644e895.tar
nixlib-9da836dd039195f0c2682adbd97fe1997644e895.tar.gz
nixlib-9da836dd039195f0c2682adbd97fe1997644e895.tar.bz2
nixlib-9da836dd039195f0c2682adbd97fe1997644e895.tar.lz
nixlib-9da836dd039195f0c2682adbd97fe1997644e895.tar.xz
nixlib-9da836dd039195f0c2682adbd97fe1997644e895.tar.zst
nixlib-9da836dd039195f0c2682adbd97fe1997644e895.zip
rancher-compose: remove
I no longer use rancher and can test this derivation.
Also rancher-compose should have the same version as the rancher cluster
used. So it is better to be build by the user using it rather having a
random version in nixpkgs.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/virtualization/rancher-compose/default.nix44
1 files changed, 0 insertions, 44 deletions
diff --git a/pkgs/applications/virtualization/rancher-compose/default.nix b/pkgs/applications/virtualization/rancher-compose/default.nix
deleted file mode 100644
index 57aa6809d6c1..000000000000
--- a/pkgs/applications/virtualization/rancher-compose/default.nix
+++ /dev/null
@@ -1,44 +0,0 @@
-{ lib, buildGoPackage, fetchFromGitHub }:
-
-let
-  generic = { version, sha256 }: buildGoPackage rec {
-    name = "rancher-compose-${version}";
-
-    goPackagePath = "github.com/rancher/rancher-compose";
-
-    src = fetchFromGitHub {
-      owner = "rancher";
-      repo = "rancher-compose";
-      rev = "v${version}";
-      inherit sha256;
-    };
-
-    buildFlagsArray = ''
-      -ldflags=
-          -X github.com/rancher/rancher-compose/version.VERSION=${version}
-    '';
-
-    excludedPackages = "scripts";
-
-    meta = with lib; {
-      description = "Docker compose compatible client to deploy to Rancher";
-      homepage = https://docs.rancher.com/rancher/rancher-compose/;
-      license = licenses.asl20;
-      platforms = platforms.unix;
-      maintainers = [maintainers.mic92];
-    };
-  };
-in {
-  # should point to a version compatible
-  # with the latest stable release of rancher
-  rancher-compose = generic {
-    version = "0.9.2";
-    sha256 = "1wlsdjaa4j2b3c034hb6zci5h900b1msimmshz5h4g5hiaqb3khq";
-  };
-
-  # for rancher v1.2.0-pre3+
-  rancher-compose_0_10 = generic {
-    version = "0.10.0";
-    sha256 = "17f3ya4qq0dzk4wvhgxp0lh9p8c87kpq7hmh3g21ashzqwmcflxl";
-  };
-}