summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2018-04-21 12:50:52 +0100
committerGitHub <noreply@github.com>2018-04-21 12:50:52 +0100
commit9d0e081e76a249ae643662094a97b09dde9520d0 (patch)
tree950dd84bf8df0298e3ba0d25a6cebd9976a47738 /pkgs/applications
parentf925ec0d4ab152be5499275e7d398d572673e446 (diff)
parent5be6943696ab515c85bec82870a15766a2b4afdd (diff)
downloadnixlib-9d0e081e76a249ae643662094a97b09dde9520d0.tar
nixlib-9d0e081e76a249ae643662094a97b09dde9520d0.tar.gz
nixlib-9d0e081e76a249ae643662094a97b09dde9520d0.tar.bz2
nixlib-9d0e081e76a249ae643662094a97b09dde9520d0.tar.lz
nixlib-9d0e081e76a249ae643662094a97b09dde9520d0.tar.xz
nixlib-9d0e081e76a249ae643662094a97b09dde9520d0.tar.zst
nixlib-9d0e081e76a249ae643662094a97b09dde9520d0.zip
Merge pull request #39212 from xeji/qemu-ga
qemu: add separate output "ga" for qemu-ga guest agent
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/virtualization/qemu/default.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/pkgs/applications/virtualization/qemu/default.nix b/pkgs/applications/virtualization/qemu/default.nix
index 7b246df01a93..f5cd661fbecb 100644
--- a/pkgs/applications/virtualization/qemu/default.nix
+++ b/pkgs/applications/virtualization/qemu/default.nix
@@ -67,6 +67,8 @@ stdenv.mkDerivation rec {
 
   enableParallelBuilding = true;
 
+  outputs = [ "out" "ga" ];
+
   patches = [ ./no-etc-install.patch ./statfs-flags.patch (fetchpatch {
     name = "glibc-2.27-memfd.patch";
     url = "https://git.qemu.org/?p=qemu.git;a=patch;h=75e5b70e6b5dcc4f2219992d7cffa462aa406af0";
@@ -122,6 +124,9 @@ stdenv.mkDerivation rec {
       for exe in $out/bin/qemu-system-* ; do
         paxmark m $exe
       done
+      # copy qemu-ga (guest agent) to separate output
+      mkdir -p $ga/bin
+      cp $out/bin/qemu-ga $ga/bin/
     '';
 
   # Add a ‘qemu-kvm’ wrapper for compatibility/convenience.