summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorWill Dietz <github@wdtz.org>2018-10-31 13:32:44 -0500
committerxeji <36407913+xeji@users.noreply.github.com>2018-10-31 19:32:44 +0100
commit9c794029620183b714e6eac63df6a9bc0e786178 (patch)
tree5cb888ce2458ce1fcf5183d745f0bceff2fe6201 /pkgs/applications
parent5f755425a1fb461b429f40c6bc5c9bf5975234fc (diff)
downloadnixlib-9c794029620183b714e6eac63df6a9bc0e786178.tar
nixlib-9c794029620183b714e6eac63df6a9bc0e786178.tar.gz
nixlib-9c794029620183b714e6eac63df6a9bc0e786178.tar.bz2
nixlib-9c794029620183b714e6eac63df6a9bc0e786178.tar.lz
nixlib-9c794029620183b714e6eac63df6a9bc0e786178.tar.xz
nixlib-9c794029620183b714e6eac63df6a9bc0e786178.tar.zst
nixlib-9c794029620183b714e6eac63df6a9bc0e786178.zip
hub: 2.5.1 -> 2.6.0, cleanup a bit (#49503)
* categorize inputs appropriately
* only put man pages into share/man; previously we copied other formats
  as well as intermediate files used in man page generation.
  (which 'man' complained about but otherwise seemed to ignore)
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/version-management/git-and-tools/hub/default.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/pkgs/applications/version-management/git-and-tools/hub/default.nix b/pkgs/applications/version-management/git-and-tools/hub/default.nix
index 113d7f78b905..e01101c6a662 100644
--- a/pkgs/applications/version-management/git-and-tools/hub/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/hub/default.nix
@@ -2,7 +2,7 @@
 
 buildGoPackage rec {
   name = "hub-${version}";
-  version = "2.5.1";
+  version = "2.6.0";
 
   goPackagePath = "github.com/github/hub";
 
@@ -10,10 +10,11 @@ buildGoPackage rec {
     owner = "github";
     repo = "hub";
     rev = "v${version}";
-    sha256 = "0a5i351v998vdwf883qhh39c15x56db01fr9hscz4ha7r9550pqg";
+    sha256 = "0hxmbpyv2yjxg4v3z50x5ikgcz7mgv5prya8jcpi277vq2s0wwa1";
   };
 
-  buildInputs = [ groff ronn ruby utillinux ] ++
+  nativeBuildInputs = [ groff ronn utillinux ];
+  buildInputs = [ ruby ] ++
     stdenv.lib.optional stdenv.isDarwin Security;
 
   postPatch = ''
@@ -29,7 +30,7 @@ buildGoPackage rec {
     install -D etc/hub.fish_completion  "$bin/share/fish/vendor_completions.d/hub.fish"
 
     make man-pages
-    cp -r share/man $bin/share/man
+    cp -vr --parents share/man/man[1-9]/*.[1-9] $bin/
   '';
 
   meta = with stdenv.lib; {