summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authoradisbladis <adisbladis@gmail.com>2018-11-04 14:14:16 +0000
committeradisbladis <adisbladis@gmail.com>2018-11-04 14:17:40 +0000
commit965ae0246a2ee176cba658503afe8cd78e01f087 (patch)
treedd51686659ed6bac3e341281a8aa9a79808c81ea /pkgs/applications
parent6795bdd58ca1f1504833428365f32bd023bb1aeb (diff)
downloadnixlib-965ae0246a2ee176cba658503afe8cd78e01f087.tar
nixlib-965ae0246a2ee176cba658503afe8cd78e01f087.tar.gz
nixlib-965ae0246a2ee176cba658503afe8cd78e01f087.tar.bz2
nixlib-965ae0246a2ee176cba658503afe8cd78e01f087.tar.lz
nixlib-965ae0246a2ee176cba658503afe8cd78e01f087.tar.xz
nixlib-965ae0246a2ee176cba658503afe8cd78e01f087.tar.zst
nixlib-965ae0246a2ee176cba658503afe8cd78e01f087.zip
pulseaudio-modules-bt: unstable-2018-10-16 -> unstable-2018-11-01
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/pulseaudio-modules-bt/default.nix10
-rw-r--r--pkgs/applications/audio/pulseaudio-modules-bt/fix-install-path.patch15
2 files changed, 18 insertions, 7 deletions
diff --git a/pkgs/applications/audio/pulseaudio-modules-bt/default.nix b/pkgs/applications/audio/pulseaudio-modules-bt/default.nix
index b377db65c0c9..cb267d8bbb66 100644
--- a/pkgs/applications/audio/pulseaudio-modules-bt/default.nix
+++ b/pkgs/applications/audio/pulseaudio-modules-bt/default.nix
@@ -5,6 +5,7 @@
 , pkgconfig
 , ffmpeg_4
 , patchelf
+, fdk_aac
 , libtool
 , cmake
 , bluez
@@ -22,13 +23,13 @@ let
 
 in stdenv.mkDerivation rec {
   name = "pulseaudio-modules-bt-${version}";
-  version = "unstable-2018-10-16";
+  version = "unstable-2018-11-01";
 
   src = fetchFromGitHub {
     owner = "EHfive";
     repo = "pulseaudio-modules-bt";
-    rev = "552c2b48c0cc7dd44d0746b261f7c7d5559e8e30";
-    sha256 = "052jb1hjx1in7bafx4zpn78s7r6f2y7djriwi36dzqy9wmalmyjy";
+    rev = "a2f62fcaa702bb883c07d074ebca8d7135520ab8";
+    sha256 = "1fhg7q9064zikhy0xxldn4fvh49pc47mgikcbd9yhsk66gcn6zj3";
     fetchSubmodules = true;
   };
 
@@ -45,6 +46,7 @@ in stdenv.mkDerivation rec {
   buildInputs = [
     pulseaudio
     ffmpeg_4
+    fdk_aac
     libtool
     bluez
     dbus
@@ -72,7 +74,7 @@ in stdenv.mkDerivation rec {
 
   meta = with stdenv.lib; {
     homepage = https://github.com/EHfive/pulseaudio-modules-bt;
-    description = "SBC, Sony LDAC codec (A2DP Audio) support for Pulseaudio";
+    description = "LDAC, aptX, aptX HD, AAC codecs (A2DP Audio) support for Linux PulseAudio";
     platforms = platforms.linux;
     license = licenses.mit;
     maintainers = with maintainers; [ adisbladis ];
diff --git a/pkgs/applications/audio/pulseaudio-modules-bt/fix-install-path.patch b/pkgs/applications/audio/pulseaudio-modules-bt/fix-install-path.patch
index 2b4ff86ab71b..e500d1fb1333 100644
--- a/pkgs/applications/audio/pulseaudio-modules-bt/fix-install-path.patch
+++ b/pkgs/applications/audio/pulseaudio-modules-bt/fix-install-path.patch
@@ -1,11 +1,20 @@
 diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 0f5baa0..1f35cce 100644
+index d869979..185144d 100644
 --- a/CMakeLists.txt
 +++ b/CMakeLists.txt
-@@ -122,5 +121,4 @@ INSTALL(TARGETS
+@@ -143,13 +143,13 @@ INSTALL(TARGETS
          module-bluez5-device
          module-bluetooth-discover
          module-bluetooth-policy
 -        LIBRARY DESTINATION ${PulseAudio_modlibexecdir})
--
 +        LIBRARY DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pulse-${PulseAudio_VERSION}/modules/)
+ 
+ if(NOT ${HAVE_SYSTEM_LDAC})
+ 
+ INSTALL(TARGETS
+         ldacBT_enc
+         ldacBT_abr
+-        LIBRARY DESTINATION ${PulseAudio_modlibexecdir})
++        LIBRARY DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pulse-${PulseAudio_VERSION}/modules/)
+ 
+ endif()