summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2017-06-23 17:45:27 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2017-06-30 10:09:31 -0400
commit95c8277701fb746ad4d91841de494ee869886991 (patch)
tree120ec8dad2d1a6d1c678f3d51778328f5ad2a110 /pkgs/applications
parentd61c22341b00171b53697164cb8241184979d14c (diff)
downloadnixlib-95c8277701fb746ad4d91841de494ee869886991.tar
nixlib-95c8277701fb746ad4d91841de494ee869886991.tar.gz
nixlib-95c8277701fb746ad4d91841de494ee869886991.tar.bz2
nixlib-95c8277701fb746ad4d91841de494ee869886991.tar.lz
nixlib-95c8277701fb746ad4d91841de494ee869886991.tar.xz
nixlib-95c8277701fb746ad4d91841de494ee869886991.tar.zst
nixlib-95c8277701fb746ad4d91841de494ee869886991.zip
misc pkgs: Remove unneeded *Platform == *Platform comparisons
PR #26007 used these to avoid causing a mass rebuild. Now that we know
things work, we do that to clean up.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/mpg123/default.nix4
-rw-r--r--pkgs/applications/editors/ed/default.nix8
2 files changed, 9 insertions, 3 deletions
diff --git a/pkgs/applications/audio/mpg123/default.nix b/pkgs/applications/audio/mpg123/default.nix
index 2909dd70ce9a..59012432caf6 100644
--- a/pkgs/applications/audio/mpg123/default.nix
+++ b/pkgs/applications/audio/mpg123/default.nix
@@ -1,6 +1,6 @@
 { stdenv
 , fetchurl, alsaLib
-, buildPlatform, hostPlatform
+, hostPlatform
 }:
 
 stdenv.mkDerivation rec {
@@ -13,7 +13,7 @@ stdenv.mkDerivation rec {
 
   buildInputs = stdenv.lib.optional (!stdenv.isDarwin) alsaLib;
 
-  ${if buildPlatform != hostPlatform then "configureFlags" else null} =
+  configureFlags =
     stdenv.lib.optional (hostPlatform ? mpg123) "--with-cpu=${hostPlatform.mpg123.cpu}";
 
   meta = {
diff --git a/pkgs/applications/editors/ed/default.nix b/pkgs/applications/editors/ed/default.nix
index 053e1d22af31..2404405c307f 100644
--- a/pkgs/applications/editors/ed/default.nix
+++ b/pkgs/applications/editors/ed/default.nix
@@ -32,7 +32,13 @@ stdenv.mkDerivation rec {
     */
   doCheck = !(hostPlatform.isDarwin || hostPlatform != buildPlatform);
 
-  configureFlags = if hostPlatform == buildPlatform then null else [
+  # TODO(@Ericson2314): Use placeholder to make this a configure flag once Nix
+  # 1.12 is released.
+  preConfigure = ''
+    export DESTDIR=$out
+  '';
+
+  configureFlags = [
     "--exec-prefix=${stdenv.cc.prefix}"
     "CC=${stdenv.cc.prefix}cc"
   ];